WIFI - unable to upload files, unable to update software and plugins

Good news - I resolved the issue on my own, however because of what it was I would like to share the solution with you. I did search here but was unable to find an answer (it may be here, but I didn't find it).

I have a Pi 3B+, and Ender 5 Plus - when I initially setup my PI I specified my 2.4G SSID - "XYZ1 / password" and had no problems connecting to the Pi navigating the interface worked great but when I tried to upload files, update octopi, or add plugins - it would appear to be doing what it should then fail without any real indication of what the problem was.

After weeks of frustration I decided to give up and go wired, it was then that I discovered the problem - when I checked the router to see what address on the LAN the octopi pulled, I noticed that it was connected to my 5G WIFI - SSID "XYZ1-5G / password". So even though I explicitly specified my 2.4G SSID and password it was still connecting to the 5G WIFI. When setting up the WIFI initially I didn't put alot of thought in the SSID names - I guess having the same password with similar names lets it pick the 5G instead of the 2.4G.

Yes - the SSID's were similar and the passwords the same.

Resolution : Change 5G SSID name to XYZ2-5G

Now it connects to the 2.4G properly and everything works as it should.

Hopefully this will be helpful to someone.

I have found lots of useful information here - would like to thank everyone who contributes - happy printing!

Nobody Important