Wifi Will not connect

I'm unable to locate the logs to assist in what maybe happening, would appreciate if someone could tell me where they are hiding, or if I need to turn them on.

I've setup my wifi SSID and PSK correctly. Have attempted to use both the wifi networks in my home. Neither show the Pi connecting to the router at any point. Ethernet works fine.

Have tried multiple power packs.

I'm a bit lost when it comes to how to fix this, as everything keeps pointing me back to the text file which isn't working. Is there something in terminal I can do to test, enable or, do something. I feel really hopeless just getting pushed back to this file where the details are correct.

Appreciate any assistance.

I'm not sure if i get it right bcs my english ist not so well. I think i had a similar problem when i set up my Octopi. When i connected it via wifi to my accespoint in my room, which is connected via ethernet to my router the pi didn't connect properly. But when i connected it directly to my router via wifi everything worked fine.
Did the pi get an ip adress when you look it up with a screen connected to the pi?

it should look similar like this:

Not when it's on WiFi it doesn't, no. I can't actually determine if there is and error. I just found access to the logs so will report back here once I'm done reading through if I can't work it out.

I had a similar issue. Is your wifi ssid broadcast setting set to "hide?" If it is, turn the hide function off. Octopi will then see the wifi network. This worked for me.

I've just gone out and purchased a Pi 4B and I'm still having the same issues. There is absolutely nothing mentioned in the logs about wifi trying to connect, or failing to connect.

I love the text file option, but can someone please give me some commands I can run to try and get this thing at least thinking about working? The only support I can really locate seems to be people referring back to the WPA file.

octoprint (2).log (43.1 KB)

Logs attached. Nothing about Wifi.

  • Multiple power cables
  • Brand new official cable
  • Brand new Pi 4

Can the SSID have spaces in it? That's the only thing I can think unless I'm missing something. Should is "just work" once I've filled the details?

Am connecting to good router, and use WiFi on multiple devices without issue. Confirmed all other pis on my network are connecting to wifi. Only OctoPrint will not connect / even consider connecting to it.

Change the WPA connection to this;


Connected immediately.

You may attach a HDMI TV/monitor to the Pi. At the end you should get a IP address provided if a network connection is established.

It's working now. I did mention above that it wasn't providing an IP, thanks for trying to help though.