Windows/macOS confusing users trying to download OctoPi zipped IMG

I've been asked to pull out several posts from another thread here. This would be an attempt to use the curl command in a Terminal or cmd.exe prompt to manually pull the zipped OctoPi image from the guysoft github repository. This is sometimes necessary if your operating system is trying to "help" you by auto-unzipping that ZIP file and harms the contents.

You might try following this tutorial. I've included work-arounds for the quirks in Windows.

I read over it. Looks like the only variation is that I dont have Bonjour on my Windows PC. Would that keep me from being able to read any of the files?

If you don't otherwise have iTunes on your remote computer, download and install Bonjour (to assist in name resolution)


The existence of the Bonjour (Avahi) name broadcasting support on your computer should allow you to just use http://octopi.local/ and have that work out. Or you might use PuTTY to the hostname rather than the IP address.

If you follow the guide carefully, this should work out. It's entirely possible that Windows doesn't want your user to be able to write to the mounted boot partition of the microSD card.

The tutorial works around bad behavior in both macOS and Windows. Both these systems want to "help" you in ways which are unhelpful. Both will try to automatically unzip the ISO image file. My tutorial uses the curl command which won't do this. It will just download the file as it is without trying to abuse it.

Alternately, plug a monitor, keyboard and mouse onto the Pi and work on it locally. You could then use sudo nano /boot/octopi-wpa-supplicant.txt and edit it. You could then completely bypass all the craziness that is Windows in this case.

Alternately, ignore the entire wifi step initially and plug in an Ethernet cable. Then PuTTY or ssh into the Pi and then make changes as I've described in the paragraph above.

So the only difference I can see from your tutorial and what I've done is to download the file using Curl, correct?

I added the unzipped Curl folder to my System32 folder. When I used this command: curl -L -o ~/Desktop/ It fails to write. I also tried to change the file name to the one current file that's available for download and that failed too.

Try instead:

curl -o ~/Desktop/

It looks like your version of curl isn't honoring the follow-links argument as it should.

Same result again. When I move the Curl folder to System32 should I be put certain files in the System32 folder or just the entire folder?

One of us is confused. There is no Curl folder. There should be a file called curl.exe somewhere and you might need a copy of this somewhere on your hard drive which is in your PATH. Your path is the place where Windows might look for things unless you put the full path to the file itself.

But Windows found curl since it ran the program multiple times for you. It gave you curl-like output when you ran it. That's a good sign and so leave it where it lives.

If I am to help you, I need to see the output of what happens when you run the last command I gave you. Thanks.

Here is the result:

Can you successfully do a cd ~/Desktop ? If so, then your computer has a basic problem in some form or fashion.

Perhaps revert back to the original OctoPi README's instructions.

Here is the output in CMD from my Windows 10 laptop. (Different PC than before)

I tried both of the commands you recommended. Both failed on my laptop as well.

The error means one of these:

  • The operating system could not find a Desktop folder in your home directory
  • The URL indicated doesn't exist
  • Your computer can't convert the indicated domain name to an IP address

I really don't know how to help you at this point. Perhaps someone else could offer advice.