Winerror 10013 after upgrading to Windows 11

What is the problem?

Receiving a winerror 10013 after upgrading to Windows 11

What did you already try to solve it?

I've disabled my firewall and anti-virus
Upgraded Python
I ran the install upgrade

Have you tried running in safe mode

Yes, same error

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Cannot start the server or login to Octoprint

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

We need a bit more than just a Windows error code :slight_smile:
Is there anything in the logs or when you start OctoPrint via command line?

Here's a screen capture during startup. No logs generated.

Looks to me like OctoPrint is running on a privileged port.
Did you change the port in the config.yaml?
If that's the case change it back to 5000 - if not try to start the server on a different port like 5001 with

octoprint serve --port 5001

I checked the config.yaml file, there was no reference to a port within the file.
Next I started Octoprint on a different port. I was able to run Octoprint and login.
I'm not sure why port 5000 would be a privileged port.

:person_shrugging: windows is an rpg for all ages :smiley:

Here is a link to the documentation - just add your new port to the config.yaml so you don't need to use the --port variable anymore
https://docs.octoprint.org/en/master/configuration/config_yaml.html#server

Thank you for your help.

I was unable to get Octoprint to use the default port 5000 with any configuration. As suggested I hard coded a different port in the config.yaml file. Even after opening the ports in Windows security port 5000 was a no go.
But everything is now working.

Thanks Again,
Jeff

1 Like

That's really weird, but who knows what windows is doing.
Glad you got it working :tentacle:

May I ask to which port you changed it (in case someone else runs into the same issue) and ask you to try it again on port 5000 as administrator? (just press the windows key, enter cmd, right click on it and then on run as an administrator for a command line with admin privileges)

We're just curious if the port can't be used at all or just not by a normal user.