Works fine off SD but Octoprint wants to raise the Zoffset

Im running a Mignda Magician X (newest firmware, also tried older firmware) with Octoprint on a Raspberry Pi 4 - 8gb (yes I know it's overkill).

Octoprint completely ignores my Zoffset and prints WAY too high off the bed. Ill take the same exact Gcode and print it locally - perfectly.

Why is octopi adding Zheight?

This is an auto-leveling printer (fully auto, no adjustment screws under the bed at all).

This is REALLY annoying and I cant find an answer anywhere other than "maybe this" or "maybe that". I tried all the maybes. None of them work.

Plenty of people are using it with the Mignda, so it's not incompatible.

Does anyone have any ideas?

Thanks
Joe

Hallo @Vaporjoes !

There have been questions concerning safe mode and the systeminfo bundle...

There was some other Gcode I needed to place in the beginning. It is working perfectly. Thank you.

1 Like

It would be nice if you would share your finding. I can be helpful if someone else has this issue.