Works from Iphone browser but not on computer? New to this so be gentle

Camera model
Logitech c270
What is the problem?
Control panel in Octoprint displays message "Webcam stream loading" but does not stream(/webcam/?action=stream). Snap shot works fine and I get an image. Stream test shows nothing. When type in on my Iphone I can see the control box stream no problem
I have also octoclient app installed on my Iphone and that works also.
Have I missed something???
What did you already try to solve it?
Tried the "nonce" work around with google extension resource over drive....still doesn't work,
Camera in PI is enabled and correct profiles assigned for camera (if this was incorrect I wouldn't be able to view stream on iphone?)
Logs (/var/log/webcamd.log, syslog, dmesg, ...)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Latest version of Octoprint, Raspberry pi 3b+ with power source UK, direct connected webcam, CR-10s printer

Update, I can get the camera to work from my laptop just not my main desktop computer which I find really strange.

Sounds like a browser site settings issue on the desktop

1 Like