Wrong temperatures only on the first launch

What is the problem?

When I'm booting Octoprint, the first print runs with the wrong temperatures. I've only one profile with PLA (tool 200°C and bed 60°C). When I set the profile in "Cible", values are correct. When I run a gcode file containing the exact same values (1) the tool sets its temperature to 60°C and Bed to 100°C (may be the max of the bed). So I stop the job because values are wrong. I set once again "Cible" to my PLA profile, values are correct. I run once again the same code and values on tool and bed are then ok. It happens all the time after the first Octoprint boot.

What did you already try to solve it?

Stop and re-run the same job makes it work.

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

did not tested

Systeminfo Bundle

octoprint-systeminfo-20221010091307.zip (31.6 KB)

Additional information about your setup

  • Octoprint 1.8.4
  • Raspberry Pi 3 B
  • Ultimaker Cura 5.1.1
  • Creality CR-10 Smart Pro
  • Google Chrome Version 106.0.5249.91 (Official Build) (64-bit)
  • Linux Arch

Please do so.

What slicer are you using? Please slice a small object (5x5x5mm cube) and upload the gcode here.

I'm using Cura 5.1.1. Here is the cube sliced with Cura:

cube_test.gcode (59.2 KB)

Giving a try into Safe mode, looks ok. So could it be a plugin issue from your point of view?

So it is.

To find out, disable all 3rd party plugins manual and enable them one by one for test.

You may start with the creality cloud plugin. It creates some issues that can be seen in the octoprint.log.

Instead of disabling one plugin at a time, you can use the binary search method where you disable half of the plugins and test. If it doesn't fail, the culprit is in the half you disabled. If it still fails, the culprit is in the half still enabled. Repeat by disabling or enabling half of the plugins in the failing half. With 8 plugins, you get to the result in 3 steps and with 16 plugins, 4 steps.

Once you solve the original issue, I believe the start gcode for the printer doesn't optimize the heating of the bed and the nozzle. There is very little point in M140 followed immediately with a M190 (the M105 in the middle is just a temperature report). Move the M104 before the M190 and the bed and the nozzle will start heating at the same time.

Hi,

You were right! It was the Creality Cloud plugin :confused: . After disabling it, no more problems.

Thanks again

1 Like