Ws2812b not working

What is the problem?
i got some ws2812b led lights that work on a normal version of pi image but yet wont work on octopi

What did you already try to solve it?
tried version of pi image and works but not working on octopi

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

Are you using a plugin for these, or going solo? External scripts, different program entirely?

And by 'don't work' you might need to elaborate. Completely blank, flashing, strange colours...?

WS281x LEDs can be quite picky - if you haven't got them setup exactly right then they will refuse.

i am using the ws218x plugin on the libary using gpio pin 10. there is zero lighting but when i used the pi os and went through a python script and that worked only.differnce is the using the gpio pin

Is that my plugin? If it is, I'll need you to grab the logs:

  • plugin_ws281x_led_status_debug.log
  • octoprint.log
1 Like

yeah thats the one i think it could be the pi as i think the pi could be broken