WS281x LED Plug IN and L C D displays

What is the problem?
i have used this neopixel plug in with an 8 led ring. for a while. And had to stop using the led when i added an gpio lcd a while ago. i recently just switched to DSI lcd display. since switch i have not been able to make this plug in work again with neopixekls. when i increase the SPI buffer size the entire pi fails to boot until i edit the file and remove the setting.

Can neopixel and this plug in work when an lcd display. are connected. A ttf touch screen. the specific lcd is the BTT (big tree tech)50 v2 lcd display.

the wiring is as outlined in the documentation using separate 5v line from buck converter. not powered from the pi but common ground.

previously before using lcd the plugin worked with the leds no converter or diode needed. even trying a diode to drop the voltage didn't work.

the setup is using endrr 5 printer with latest octopi and octo dash with pi3. for the plug in all default setting as described in the documentation. Gpio 10

What did you already try to solve it?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

My guess is that when you installed the SPI display, some software settings were changed that mean the plugin no longer works. It should work OK with the DSI-type displays.

Could you post your full /boot/config.txt file, as well as maybe some more details about your old SPI display - a link to some install instructions might be good so I can see what it did.

If you have a spare SD card, it could be worth flashing a fresh OctoPi setup & trying to get the plugin & screen working on there, if it works we can say it is almost certainly some kind of lingering software configuration/

Config file is attached.

Sorry if this is a duplicate, tried to respond to teh email but did't show up here..
Here's the responce ..
The display was a generic 3.5 inch GPIO LCD using the LCD_show libraries / drivers. I can probably find the instructions that came with the display but really I just googled LCDshow.. or the LCD wiki. I suspected it may be some reminiscence of it's changes. Any suggestions on how to remove it? I came very close to building a new image as i also had Xwindows/X11 issues too. But a forced desktop install seemed to have corrected it...
For once I'm missing the MS windows add/remove driver :<

here's the file. the forum setting prevent attaching the actual file

For more options and information see

Raspberry Pi Documentation - Configuration

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default "safe" mode


uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display's size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Uncomment some or all of these to enable the optional hardware interfaces


Uncomment this to enable infrared communication.


Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)



Enable DRM VC4 V3D driver on top of the dispmanx display stack


hdmi_cvt 480 320 60 6 0 0 0

My apologies for the delay in looking at this and replying for the config.

There are extra lines added in there by the LCDshow stuff, and looking at the scripts there is a lot more that is configured across the Pi. This is the contents of the script for a 3.5" touchscreen for example.

I am unfortunately not sure exactly what would be conflicting, so I can't really say what to do to fix the issue.

I figured there more going on then the LEDs issue.. Had some x11 issues as well.
I ended up building a new octo server. which took care of the crashes. And eventually got the the LED strip working again.. May need to redue one of the connectors, may not have been making a good connection to the Neopixle.

Thanks for trying .. until the next issues popups..

1 Like