X/Y axes both half an inch off


#1

What is the problem?
Every print is offset by roughly half an inch from the origin. The GCode visualizer shows everything perfect, but when the print starts it's not in the right spot. This leads to large prints exceeding the boundaries and throwing everything off.

Actual print (little dot is the corner)

Forum will only let me put a single image, so image of GCode viewer - https://imgur.com/a/uiOKu8w

What did you already try to solve it?

  • Changing my slicer settings.
  • Custom bounding box in various ways, but that didn't seem to do what I want.

Various guides seems to imply the the bounding box should help fix it, but that didn't work in any of the configurations I tried.

Additional information about your setup

  • Versions - OctoPrint 1.3.9 running on OctoPi
  • Printer - Printrbot Simple Metal
  • Slicer - Simplify3D
  • Profile - Using the default Printrbot profile

#2

It's your firmware's responsibility to correctly interpret the commands that get created by your slicer and sent to it (here through OctoPrint). For some reason it appears to think it needs to apply an internal offset which leads to the coordinate shift you are seeing. I'd start with checking my firmware's EEPROM settings and config.

The bounding box has nothing to do with that, it merely tells OctoPrint that something outside of the regular build envelope is still safe to move to, so that it won't warn you when you try to print a file where the printhead moves outside the bed borders.


#3

Thank you! In case anyone else finds this thread, updating to the Modern Marlin firmware fixed my issue - https://github.com/Printrbot/printrboardmodernmarlin/blob/033622e1249a0bd2fc379eacbeee8a943e5bb621/README.md

This must have been a long-running issue that I just never noticed.