Y Steppermotor stops randomly working during print for a short time

What is the problem?
When I use Octoprint there is at a random height a shift in my print. First I thought something with the is bad or the steppermotor is broken. Yesterday I saw the issue with my eyes. The shift was caused because the Y axis steppermotor stops turning while the X axis is still moving. After a few seconds it starts turning again.

What did you already try to solve it?

  • I checked all my wires and replugged all the connections to my board.
  • I disassambled the steppermotor and checked if something is blocking it by turning the shaft or if some dirt or dust is causing it to stop turning.
  • I started the same print from my SD card and the issue was gone. The print came out like it should.

So after investigating I know that the issue is caused by Octoprint. I then started to look into the logfiles but I think there seems everything to be ok.

I'll reprint the part today and then post the octoprint.log and serial.log here.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)
Octoprint Version 1.5.3
OctoPi Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.1
Ender 3 Pro with Marlin on a Fysetc Cheetah 1.2b board

I also read that there are some issues with serial connection caused by Marlin. Because I'm new here and start looking into the threads now maybe someone knows this issue or maybe it sounds familiar to a similar one?

Any help would be appreciated.


Hello @o-r-3-o !

Have you tried safe mode?

Also you may check the motor current and for overheating of the motor and the drivers

I started to print one object in safe mode. If the issue still persists I'll post the logfile here later.

Overheating on steppermotor or driver shouldn't be a problem, as I can print from the SD card without any issues.

1 Like

ok so it happend in safe mode too.

Here are the logfiles
octoprint log -> pastebin.com/2ZB7uFSb
serial log -> File-Upload.net - serial.log

plugin_softwareupdate_console and plugin_pluginmanager_console are empty.

I followed the link for the serial log but I got " Website blocked due to reputation" and I'm not about to continue past that point. Since this log is probably essential to helping to solve this problem, please post it on a more reputable site (I had no problem with pastebin).

The serial log is ~14MB big so pastebin is not working.

Any other sites where I can post the file?

can you try this https://www.file.io/download/w2ZpCVIblaaj
or this https://drive.google.com/file/d/1B-MNHIIti6qjNFIhZpDFFLsgw9nyI3eI/view?usp=sharing

The file.io link worked (although it claims the file will be deleted after download). The google drive link gave me an "access denied" error.

I've used https://easyupload.io/ and https://www.mediafire.com/ successfully.

I don't see anything unusual in the serial.log. There have been other reports (in this forum) of Y stepper problems with the Ender 3 but it appears that you have replaced the stock Ender 3 controller board and firmware. Maybe someone else will have something useful for you.

hope this one works better. sorry for the inconvenience :slight_smile:

BTW: You can compress the log. It gets quite small.