YawCam Camera doesnt show video remote system Octoprint Control

Camera model - any Camera I am using WebCam and Notbook Camera
probelm ; no Video stream - conrtrol stuck wit hte following error
Webcam stream not loaded
It might not be configured correctly or require authentication. You can change the URL of the stream under "Settings" > "Webcam & Timelapse" > "Webcam" > "Stream URL". If you don't have a webcam you can also just disable webcam support there.
Currently configured stream URL: http://10.100.102.25:8081/video.mjpg

this is happaining on a windows 10 system at my home in the same network as the Copmuter which connect to the printer oocptorint run on port 5000 ; conrtrol camera doesn't work
however everything is working fine when runing on the computer that conenct to the printer with the local cameras including octoprint control and the system is printing fine and can transfer files etc...

Browser - Chrom.
octoprint and Yawcam latest version
using Port 5000 for Octoprint
Camera stream port 8081
Snapshot port 8888
I also tried port 5001 for octoprint
and ports 8082 and 8889 for the Webcam but issue the same
any idea what coudl be the problem to see camera on other computers?

thanks
Ilan

1 Like

Is your octoprint server running on a windows 10 pc?
If yes - we had a similar case a few weeks ago - maybe you got the same problem

No,
server is running on Windows 8

Well it could also be the firewall then.
Read the thread and maybe you can do it the same way :slight_smile:

Hi all

problem solved it was firewall problem in the remote system ( win8 connected to the printer)
not sure why its happen since port 8888 and 8889 work fine with out any adjustments.
you can either open the Firewall port for 8081 and 8082 ports in the firewall interface under control panel, or better option to open "cmd" command window as administrator and run the following command : netsh advfirewall firewall add rule name=L2TP_TCP protocol=TCP localport=8081 action=allow dir=IN

Thanks