Yawcam won't display in OctoPrint control page

Camera model

Cheap Chinese: Cuwada L012

What is the problem?

yawcam version 0.7.0 is running on Windows 11. It works great. I have it outputting a 640x480 @ 6fps and snapshot. I'm not using it on the internet - only local network. On any local network machine and on any web browser, I can see both the stream and the snapshot. I use http://:5055 and http://:5056 respectively.

Stream doesn't show in OctoPrint on the Control Tab, and gives a "Webcam stream not loaded" message. It also says currently configured stream URL: with the correct url. If I click on that url, I get a new tab and the yawcam stream runs perfectly. It just won't show in the OctoPrint window.

OctoPrint version 1.9.2 is running on RPI4, Debian Buster. Python version 3.7.3

What did you already try to solve it?

Tried different browsers. Tried all of the fixes in other yawcam threads. I've run yawcam both as javascript and mjpg. Both work in any browser I've tried, but not in the control window of OctoPrint.

Run yawcam as a service and in the foreground.

Have you tried running in safe mode?

No. Because I'm using the Classic Webcam plugin and safe mode disables all plugins. Correct me if I need to do this.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


octoprint-systeminfo-20230828042451.zip (17.4 KB)

The link you're probably looking at has some extra elements on the page that show the stream. OctoPrint just wants the pure mjpg stream, so you need to point it to the right place to get that. According to the setup guide, these are the URLs one would use:

Safe mode disables 3rd party plugins only, but Classic Webcam is not 3rd party so it does not get disabled.

Thank you very much. That was it. I managed to breeze over that bit because I had it working on my browser with the port number alone. Now, its working as expected. My bad. RTFM. Thank you.