Yet another camera problem

I have a problem with the camera port on my Raspberry pi 4. I recently bought a camera (1.3) which I planned to use on the camera port on the raspberry pi board. However, I cannot get this to work. I receive the same errors as so many others, and solutions to these other problems have not solved my problem.

Here is the description:

The camera is detected by the Raspberry pi:

pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=1

But when trying to take a picture this happens:

pi@octopi:~ $ raspistill -v -o test.jpg

"raspistill" Camera App (commit f73fca015d42 Tainted)

Camera Name ov5647
Width 2592, Height 1944, filename test.jpg
Using camera 0, sensor mode 0

GPS output Disabled

Quality 85, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Time delay 5000, Timelapse 0
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Flicker Avoid Mode 'off'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera preview port to video render.
Connecting camera stills port to encoder input port
Opening output file test.jpg
Enabling encoder output port
Starting capture -1
Camera control callback  cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

I was certain that the camera was broken, so to verify that I plugged the camera into an old Raspberry pi B from 2013. When I booted up that old piece the camera was working! Also, on the old board the red lid was lit, but it was not lit on the new board. This verified that there was nothing wrong with the camera, or that the new board wasn't backwards compatible with that old 1.3 camera. I didn't think that,
but to verify I bought a second camera (2.1) and plugged that in with the same behavior. Working on the old board, did not work on the new board. The image and conf running on both boards are the same (Octopi 0.17.0). By checking http://octopi.local:8080 I just get a page with the text "Snapshot and Stream" that keeps loading. No pictures/stream is shown.

The next test I did was using an USB webcam (Logitech C920) with the new board, and this one was working on the new board out of the box. This was nice, but I want to use the raspicam instead.

These are the things I have done:

  • Enabled cam in raspi-config
  • Updated system with:
    sudo apt update
    sudo apt full-upgrade
  • Verified that the ribbon cables and sunny connector is correct. Both by using the camera in a second raspberry pi, as well as doing continuity checking between the pins on the board and on the camera. The continuity check also rules out any cold soldering etc.
  • Done some voltage measuring on the pins while running the raspistill command (for example, the chip enable pin goes high (3.3V) when the command is active).
  • I have a 3A power supply to make sure
  • Increased the GPU mem to 256 instead of 128 in /boot/config.txt

These are my questions:

  • Is it possible that some chip that handles the raspiport on the board is broken? I find this hard to belive since the USB cam was working, and I guess the webcam data (whereever that data comes from) is handled by the same chip. But maybe that assumption is wrong?
  • Is is anything else I can try ti get the raspi-port to work?

No, the raspberry pi camera uses a very different way of communicating with the system than USB cameras. Cameras that connect to the CSI connector (which you refer to as raspiport) supplies raw image data almost directly to the GPU. USB cameras go through - well - the USB port, and give the CPU either YUV data or (M)JPEG data (or in some cases H.264).

Thanks for the reply!

That information was interesting. So, if I understand you correctly, what you basicly are saying is that there is a possibility of a hardware problem on the Raspberry Pi4? Possibly the GPU? I've only used it in headless state, where I SSH into it.

Although I think it is wierd that the LED doesn't light up either, since that doesn't have anything to do with the data from the camera. It's just a simple voltage feed.

Is there a way to verify if the GPU is malfunctioning without using HDMI-micro cables? (I don't have any).

I would suspect the physical connector before the GPU. The GPU is such an integral part of the SOC that if the GPU were broken the RPi likely would not even boot.

A small update.
I got myself a new Raspberry Pi 4, and the same camera worked flawlessly in this new unit. So apparently there was something wrong on the first RPi board/CSI-port.