Yet another Wifi issue - Connected to WiFi but not able to SSH

Hi everyone, I woke up today to a problem I did not have before, my RPi 3 Model B with OctoScreen and latest Octopi suddenly did not connect anymore via web nor ssh.

So here is all I did:

  1. I'm sure it was connected, not only was I able to see that through octoscreen, but also connected the pi to a display and sudo-updated it.

  2. Tested 2 different sd cards, with brand new images.

  3. Tested on another new RPi 4 (Since it could be a board issue)

  4. I did not change my router nor it's settings since yesterday.

  5. Wth could have happened? I am also not able to connect through the phone's browser, but this I'm not sure was possible before, I just don't have another PC around to test if it's a Windows issue. I'm lost on things to do.

I've seen aorund here while searching too that I had to enable something about exclusivity of IP adress on my router? Did not find that option. The router is a Nokia G-2425G-A

I'm open to suggestions on things to test lol. Thanks in advance! I'm writing this in a rush, so if I missed any info, please let me know.

Edit here with more info and tests:

As per recomendations from this post, I've enabled AP isolation, no deal.

Also cannot find in my router the option to "Change it to a reserved IP", so can't test this.

In my router it lists the octopi as 192.168.1.17.
Now comes the crazy part, it's listed as innactive, but if I put the Pi on my monitor I can use the internet from the console. What the?

Trying to ping that adress:

Hi there, step 1, change the name of your octopi instance - edit /etc/hostname or use raspi-config. You should always change the name of each pi, otherwise you just have a lot of raspberrypi hosts on your network, and that is guaranteed to mess up connectivity to every instance if you only use the name to connect to.

Having multiple machines with the same name is a no-no. If you don't run a local DNS server - not the router, router DNS' services are brain dead in comparison with running dnsmasq - the fallback is to use multicast name resolution, known by a variety of names including Avahi and Bonjour - this works great, provided you have unique machine names :-).

Try using the IP address instead in the browser bar instead of the name - that should always work, provided you have the right address from the DHCP table..

Step 2 - your router uses DHCP to provide an IP address so look for your router's DHCP settings - you should be able to find a table of addresses allocated by the DHCP server in the router - by changing the Pi you also change the MAC address of the WiFi adaptor. Which means your DHCP list could be confused with the same name [of the Pi] assigned to a different MAC address. Look for the IP address lease lifetime - or duration, change this to a short value - e.g. 1 hour, or even less. Wait for the lifetime to expire, then restart the Pi.
Then check the DHCP Allocation table in the router.
Give that a try and post the results here...

Thank you for the reply, I tried your suggestions, but it still won't work. I usually only connect to the pi through the IP adress itself usually.

By changing the device name in etc/hostname, here it's showing up on the router. Same adress still.

And I can successfully ping it this time around, which I could not last week. (Can't post the results here because I am a new user)

About your number 2 suggestion, I tried that again when I tested with my pi4 board, still no dice, even tough the mac changes.
I'm thinking it's a windows issue then? I'm using Windows 11 btw.

Have a read of this post, and the one below it.. Inconsistent connection and unusual IP returned by DNS - #14 by rcw88
My last work laptop was Windows 10 and it did all sorts of odd things despite having a properly configured IP address on my home network - but the most useful thing was giving my network a proper network name configured on the networks' DNS. That stopped the machinename.local problem. Try opening a command line on your windows machine and typing ipconfig /all - you are looking for the lines which have your local network address - which I appreciate you may not be able to post the results yet..

Nothing seems to work unfortunately, I now added an ESP-01S to my board to compensate for the lack of octoprint (compensate is a strong word lol), and I also can't access it through my router, I'm having to use it as AP mode, and access it directly.

It's a really strange router behavior, since it was working before, and I also cannot change it because my ISP supplied and it also accounts for our phone here. So well, I'll have stick around with this for a while until I find a way to make it work. Thanks for your suggestions.

I would highly recommend disabling DHCP on your ISP's router and installing dnsmasq on any debian or ubuntu server - so any small PC / mac mini or Pi if you have a spare one with an Ethernet port. Then you have full control over the IP configuration of every device, even your work laptop, Windows 10 will still have to connect to your local network and your browser should still be able to connect to the web gui of Octoprint - even with a heavily locked down browser that directs everything to an off-net proxy, which clearly yours doesn't.

Most ISP's routers are designed to be brain dead so the average internet user doesn't break anything, but you need more control of the IP configuration which your router will not give you, I can upload an example dnsmasq configuration if you want to try one that works.