Z axis homing in the wrong direction


#1

What is the problem?
I bought a fastbot bbp 1s a couple years back and have just now hooked it up. I have all the stepper motors working as well as end stops, hot bed, hot end, and fans. I haven't got the touch screen going yet, but that is a hole nother issue. The biggest problem I am having is that I can't figure out how to get the z axis to home up instead of down.

What did you already try to solve it?
So I have looked and looked for a way to change it, and all I have been coming up with is to do it in the firmware? I have tried to invert the motor direction in the settings and all that does is make it go the opposite direction when running manually. Inverted or not it still homes down, not up. I'm not even sure how to access the firmware on the board.
Yes, I'm a newbie. I've been in construction for 23 years, I can build just about anything. I'm just not very computer literate.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Try to swap the z-motor connector by 180°


#3

I also note that on my printer the bed moves up and down rather than being stationary like many out there.

So in OctoPrint -> Settings -> Printer Profiles -> my printer -> Axes -> Z axis "invert control" checkbox is checked on mine


#4

Continuing the discussion from Z axis homing in the wrong direction:

Now i really feel like a ding dong!! LOL Like i said before, i have been in construction for 23 years, and i totally understand flipping polarity. I just assumed that in i inverted it in the settings menu that it would do it on the controller. So thank you, that did the trick! Now on to my next problem, getting to start printing from the center of the bed not the home position.


#5

Settings -> Printer Profiles -> your printer -> probably first tab -> change it to center origin


#6

my printer settings does not have that setting??


#7

Okay, make that "second tab":

12%20PM


#8

I'm not using the octoprint slicer, I'm not quite savvy enough to set it up on windows. It just looked super complicated. The board I'm using is a fastbot bbp1s, I picked it up during the kick start campaign about 3 years ago. It has a form of octoprint already on it, but no slicer software. So I'm using cura for slicing. I did figure out how to get it to print in the center of my bed. The print setup gcode needed to have a specific location. So after the home code I added G1 X165 and G1 Y165 and it worked.
So that hurdle has been jumped, now the next one!:confused: I started with an easy test print, a small plate that says hello world. First issue was the hot bed would not surpass 44C, I just changed the target temp so it would start the print. Once the print started (which didn't stick well) it made it about half way through the first layer and then the bed and hot end shut off and wouldn't turn back on.
I found some "old" updates on the wiki site and tried to do an update, which didn't work. I'm starting to think that this "really cool and awesome controller " is a piece of junk?
So if you don't mind me asking, what's your opinion, and what is the easiest to use board? I've been looking into the smoothie and the duet wifi?


#9

Neither am I. But if you expect to use the buttons on the Control tab, you should still configure it there in the Settings so that OctoPrint knows how to do it right.

Note that a brand-new OctoPrint installation requires you to press the Home X/Y and Home Z buttons before it will do anything, btw.


I've only got two controller boards today under my belt (both Robo) and a single printer. I'll be purchasing a Smoothieboard in January for some development. I hear goods things about the RAMPS v1.4 boards.