Z-Axis lifting between home and purge line

What is the problem?

CR-10s Pro V2 with BLTouch (RPi3b+ and RPi4)
After printer completes autolevel (G29) it goes Home to the center of the bed, stops and checks home position and on the way to do the purge line on the left side of the bed, the hotend stops halfway and starts to rise. If I am not there watching it, it will raise as high as it can go and continues to try to rise vibrating at the top.
This just started happening in the last month after my older version of OctoPrint updated. I do not remember what version I was previously using, as I have updated Octoprint every time I get a notice to upgrade it.
I am currently using Cura 4.6.1 on a Windows 10 PC connecting to RPi with OctoPrint Version 1.4.2

What did you already try to solve it?

I have tried using 2 different RPi's (RPi3b+ and RPi4) with the same installed version.
If I wipe the RPi clean and reload it with OctoPi, complete the setup again, it may work the first time and then goes back to lifting the Z-axis on the next print. I have done tis multiple times.
I uninstalled Cura 4.6.1 and reinstalled it.
I loaded the new version of Cura on a different PC, rebuilt the RPi's and tried printing from it and the printer does the same thing.
My last attempt, the printer completed the purge line and on the way back to start the print the nozzle dove into the bed destroying the glass bed and bending the hotend. I have not attempted to try using Octoprint since I repaired the printer.

If I save the file to the SD Card, the printer works perfectly.

Have you tried running in safe mode and if so did it solve the issue?

No

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I did not have any logs enabled when the issue happened. The last time I tried using Octoprint it did a purge line and then crashed into the bed destroying my bed and bending my hotend. I have not used Octoprint since.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

CR-10s Pro V2 with BLTouch (RPi3b+ and RPi4)
I am currently using Cura 4.6.1 on a Windows 10 PC connecting to RPi with OctoPrint Version 1.4.2 via MS Edge browser

Hello @Gommee!

So please do.

So please enable the serial.log and try again. Switch off (or better reset) the printer immediately when hardware issues (smashing against something) occur.
These logs are vital for understanding what is happening.

Also try printing from OctoPrint without a SD card in the printer.

Please upload the gcode file, and it would really help if there was a serial.log available. We don't have superpowers to see whether maybe there was a communication issue, or perhaps a plugin messed with the gcode as it was being sent.

The other issue you might have is Creality. Thier firmware seems to do strange things when connected via USB, from ignoring endstops to thermal runway errors - but only if you don't have an SD card in. Strange, I know.

My suggestion is to update the firmware. It's not normal for OctoPrint to cause such issues with the printer, it really does sound like a firmware crash to me.