Z axis offset ignored?


#1

When printing the same gcode from octopi it dont stick to the bed and i have yet to make a whole print after (10-15) tries.
The same gcode file in the sd card reader prints perfect.
i have an z offset of 0.3 and it seems like that is the one it is ignoring when printing from octopi.

The weird thing is that when i use the terminal in octopi ( after a tip i read in a forum) it reports back with the correct offset

I'm printing on a Tevo Tornado and this is my first printer , so i am a super noob. (remember if you can explain )
PI 3 new


#2

I ran into a similar issue with octoprint 1.3.6 with Marlin 1.1.8. all terminal functions seemed to be fine but when I started a print off the SD from octoprint, it ignored the offset. But when I removed octoprint from the picture, it worked fine. I hope to play around with this more this weekend.


#3

Are you slicing an STL on octoprint, or sending gcode to octoprint?


#4

Playing around with my setup today, I had no issues. I was starting prints from SD.
When I was having problems, I was issuing commands via the web terminal, and I think it may have either been ignoring or caching the z offset. I may be able to do some more testing tomorrow evening or early this next week.


#5

I had a similar problem setting a Z axis offset on a Tevo Tornado the other day. I am also a super noob. It took many tries to figure out how to get it and the bed adjusted. but now it finally works. I wish there was an Owner's Manual with the Tornado that explained all the command and setting options. Most of the time, what I read from people's posts is all greek to me!


#6

Okay so I took a few minutes tonight to play around with this.
It seems like its actually (in my case) a Marlin "issue".

If I home XYZ, then change the Z offset, then use a G1 Z0 command, it uses the last known Z offset during the homing. So basically if you change your Z offset with M851, to use it, you need to re-home Z.

The same goes for controlling the printer from the LCD.

So in the end, if you change the Z offset, do not forget to re-home Z. :smiley:


#7

Sorry to bring up an old thread, but I'm having this exact issue as well, and I can't find a solution. @loclhst I'm a little confused on what to do from your suggestion.

I started an Octoprint forum thread here for my issue