Z Home problem with two Z endstops / Z Home Problem mit zwei Endstops

Hi there!

I switched back from Lerdge-K to SKR1.3 and have a big problem now.
My Sidewinder x1 has an additional second Z endstop and worked fine with the Lerdge Board.
Now i have switched back to SKR 1.3 and Marlin for some reason and have a mystical problem with homing the Z axis.

When i send the print over Octoprint(wifi) - and the gcode performs G28 after heating, the second Z Stepper with the second endstop will not stop when the second Z endstop is triggerd and the Z Axis crashs into the bed.

What works:
Home the Z Axis with the TFT Display in the Movement Menu
Home the Z Axis with the TFT Display in the Gcode Terminal with G28
Home the Z Axis with pronterface
Home the Z Axis with the any slicer controll
print over USB, SD Card

Home the Z Axis with Octoprint controll buttons works also fine!
Home the Z Axis with Octoprint termianl and G28 works also fine!

What have i tried to solve the Problem?
-new octoprint install
-checked my Marlin config
-tried several slicers (Prusaslicer + S3D)
-tried Xmax instead of Zmax for the second endstop microswitch.

-SKR1.3 with TMC2209 and TFT35
-Octoprint,latest 1.4.0

at this point, i'm out of ideas...

Cheers, Markus

Hello @MarkusN!

So, what gcode command is used to home the Z axis in the print file?
Maybe you have to reconfigure the startcode in the slicer.

Hi Ewald!
here the first lines from a Prusaslicer file:

here what Octoprint shows:

the startcode is stepwise reduced for bugfixing and now the only command is the G28

@Ewald_Ikemann, you need more information?

Sorry, I've been to work...
So, when the firmware accepts G28 from the terminal but not from inside a print file with line number and a checksum, I assume it maybe could be a fault inside marlin.

But you can try this:
Instead of just G28 in the start script, you may can try this

G28 X Y
G28 Z


Hi @Ewald_Ikemann!

i have tried that but have the same trouble with splitting the G28 .

Have you already consulted the marlin forums?

I haven't done that. Till now, i thought that's a Octo Problem

It works fine from the control tab and from the terminal.

Referring to the log you sent, G28 is properly sent to the printer.

Send: N5 G28*22
Recv: echo:busy: processing

And there the issue happens.

I seems the issue happens in the firmware.


right now I'm flashing bugfix. I will call back soon


unfortunately the same bug with marlin bugfix 2.0.x (April)

Printers with two Z endstops are not uncommon, I wonder that there are no more questions on the subject

So, does this also appear when you print from SD card or from pronterface?

Only when i print over Octoprint, it works fine with SD Card and USB Stick!

And pronterface?

i use pronterface only for testing the hardware. Is it possible to send a print job with pronterface? I'll try that.

Yes, you can.


Ok, i have send the same print file with pronterface and that works fine! No problems with Pronterface

But from your log excerpts I can't see OctoPrint is doing something wrong.
I still recommend to ask a marlin forum about this. It's always better to seek on multiple sides.

Thanks for your help @Ewald_Ikemann!