Z-offsets are ignored in every way

What is the problem?

I tried numerous ways to set a z-offset and octoprint ignored it every time. I can set the offset manually after starting a print from SD card but that can't be the solution here.

What did you already try to solve it?

  • Custom start-GCODE in Prusaslicer, Octoprint and manually adding it onto the file (G92)
  • Using the z-offset setting in Prusaslicer
  • Setting it with M206 and then M500 in Terminal and GCODE.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20231024235504.zip (65.9 KB)

Additional information about your setup

Octoprint V1.9.3, Ender 3v2

Hello @derFelix244 !

Have you checked the value after you set it with M206?


If you print from the printer's SD card, OctoPrint can not influence the print in any way except cancelling and abort.

You may try M290 instead of M206


I will try checking the value and usinfg M290 later today.

What I meant by manually setting the offset was by printing entirely without octoprint to indicate that the offset can work.

I'll report back to you.

1 Like

OctoPrint doesn't do anything with the z offset - it is the printers responsibility to read the command and do something. We've seen it before where some Creality firmware required the SD card to be in the printer, even when printing from OctoPrint, or it would do daft things like this. If you can see the command sent in the terminal and acknowledged by the printer, then it's probably not an OctoPrint problem but something in the printer firmware that's treating USB printing different.

The printer acknowledges the commands to change the z-offset but it won't affect anything. I have the SD always plugged in. Do you think it would be an idea to switch to another firmware? If yes, do you have recommondations?

It also seems that the Printer uses a different z-offset everytime it prints.
A new Firmware might also be a step closer to finally get finde prints again because i have a few other problems that I don't know how to fix.

I would also look into a BLtouch if I can't fix the problem otherwise.

I installed a new firmware where i could set the z offset properly and the printer finally prints again. last thing left is getting proper bed adhesion.
thank you both for oyur hel regarding my problem.

didn't work

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.