0.17 file corrupted on SD card?

Good morning folks, I am very new to the 3D printing world and I need a little help. I downloaded the new version of Octoprint zip file on Windows 10, and when I try to write to my SD card with either Ecter or Win imaginer it tells me the files are corrupted. Now I have been following different videos on YouTube to how to install Octoprint, but I can not open the files to make the changes. I am as green as the grass to doing the G code installations, but I do want to learn very much in the future, but first want to install the Octoprint, so please can someone help me in a simple state.
Thank you from the far north, Mark.

  1. Download and install balenaEtcher 1.5.81 from https://github.com/balena-io/etcher/releases.
  2. Download and install WinMD5Sum from https://sourceforge.net/projects/winmd5sum/.
  3. Download OctoPi 0.17.0 from https://octoprint.org/download/. Make a note of the MD5Sum under the download button.
  4. Run WinMD5Sum against the OctoPi download and verify that the MD5Sum matches.
  5. Run balenaEtcher specifying the OctoPi .zip file that your just verified.
  6. Follow the Setting up OctoPi instructions on https://octoprint.org/download/

If you are still having problems, try a different SD card.

Afternoon b-morgan, thank you for your help with this problem I am having, I did run the MD5Sum program and the numbers do not match. Do you have any other ideas, as I have searched the web to see if l can fix the problem.
Thank you

Download the .zip file again and check the MD5Sum. If you can't get a good download, there's not much else to do. You can try https://github.com/guysoft/OctoPi/releases for an alternate site.

If you have multiple failures, then you might try to find a friend that could download it for you. If you have no friends :pensive: you could order one of the All-in-one OctoPrint Kits :rofl:

You generated the md5 for the zip, right?
It's only the md5 for the zip - not for the unzipped image

Good evening PrintedWeezi, sorry I am very new to this and do not know how to generate the md5 for the zip, sorry still in the learning stage.

I mean when you use the MD5Sum program you have to select the zip you downloaded - do not unpack the zip and use that program on the unpacked file :slight_smile:

I did run the MD5Sum to verify they match, which they do, but still get the " disk imaginer file is corrupted" I dont know what to do next.

Since this is new for you, are you downloading the zip file to your SD card? If so, that is your problem. The zip file should be downloaded to a place on your system. You point Etcher at the zip file on your system and it overwrites everything on your SD card. The fact that the MD5 sums match means the zip file is NOT corrupt.

1 Like

I did download to my hard drive TxBillbr, and I tried Etcher but it tells me this on my screen.

You are trying to mount the image. You cannot mount the image. You have to flash the image to your SD with etcher, eject the card, reinsert it, edit the WiFi config, eject the card, insert it into your powered down pi, power it up and then take it from there.

Good afternoon foosel, here what I get when I fry the Etcher to flash to my SD card, I have tried at least a dozen times and get the same thing and it is a new card and has been formatted by SD Card Formatter program. I tried on a different card and the same thing and I did a flash to other card with a different file and had no problems. I do not know if I have missed something as I followed the download instructions and anything else I can figure out.

Mark, What is the brand/type/size of SD card you are trying to use? Is it large enough (I would suspect it is)? SD cards come at several different levels. Take a look at https://kb.sandisk.com/app/answers/detail/a_id/2520/~/sd%2Fsdhc%2Fsdxc-specifications-and-compatibility. What type of device are you using to operate on your SD card? Can it handle the spec of the card? I had a problem with large cards and my SD programmer last year because my programmer was old. Also are you putting the SD card into one of those small-to-large adapters? Sometimes those have problems.

I normally take the card out of the package and start Etcher on it. We'll just keep working on this until we find where the problem is. :smiley:

Thanks TxBillbr, I appreciate everyone helping with this little burb. Here is the SD card and the adapter l am trying to us, it seems to be the most popular one people are using.

I have also run some tests on my laptop through, command prompt, sfc\scannow and DISM check and just finished chkdsk. And there is no problems on that end.

Instead of balenaEtcher (abreviated Etcher) try Win32 Disk Imager instead. I believe you will need to extract the image from the .zip file manually (which is why Etcher is preferred by most people because it works directly with the .zip file).

Brad, that is a good idea too. I don't use Win32 Disk Imager, but I know that a number of folks do.

Good evening Brad, I did try Win32Disk Imager and got the same error as on Etcher.

Mark, I can't remember which way the little slider goes on the adapter. Make sure it is all the way up/down as this turns off/on write protection. They slide easy and if in the middle, no telling what it does.

Maybe not. My SD gizmo doesn't like the adapter very much.