Actual temp stays at zero when trying to set target temp

What is the problem?

When I start a print the target temp will be set and the actual temp then acts as normal and raises to the target temp. However, when I try to set a temp without starting a print it will stay at zero. The actual hot end does heat up though.

What did you already try to solve it?

  1. I turned everything off and on multiple times
  2. Checked wire connections
  3. Made sure there wasn't a card in the printer
  4. Ran in safe mode
  5. Checked for software updates
  6. Tried typing in temp and setting temp using drop-down arrow

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (182.4 KB)

Additional information about your setup

**OctoPrint version:**1.9.0,
**OctoPi version:**1.0.0 ,
Printer: Ender 5,
Firmware: Marlin,
Browser: Chrome,
Operating system: Windows 10
Additional Equipment: CR Touch
Silent Mainboard

Any help will be greatly appreciated.

Need you to turn on serial.log so that we can see the communications to your printer.

Turn it on and then do the thing that seems to not be working and send us the new log. You likely will want to turn it off after that.

I did also see a few errors in your OctoPrint.log but I don't think it is related. However you likely should try to fix that too.

Blockquote2023-06-14 21:52:23,946 - octoprint.environment - ERROR - Unexpected error while detecting environment
Traceback (most recent call last):
File "/home/Warriorie/oprint/lib/python3.9/site-packages/octoprint/", line 130, in _detect_from_plugins
additional = implementation.get_additional_environment()
File "/home/Warriorie/oprint/lib/python3.9/site-packages/octoprint/util/", line 1686, in wrapper
return f(*args, **kwargs)
File "/home/Warriorie/oprint/lib/python3.9/site-packages/octoprint_pi_support/", line 374, in get_additional_environment
File "/home/Warriorie/oprint/lib/python3.9/site-packages/octoprint_pi_support/", line 528, in _check_throttled_state
command = self._settings.get(["vcgencmd_throttle_check_command"])
AttributeError: 'PiSupportPlugin' object has no attribute '_settings'

I am not sure what to say this is.. my first thought on it would be that your Pi is overheating maybe. Not sure. Maybe someone else can help a bit on that one.

Open OctoPrint Settings, Serial Connection, Intervals & timeouts. What are the values of the Temperature Interval settings (first 3 values)?

After setting a temperature without printing (the failure case), switch to the Terminal tab and see if there are any temperature reports, you may have to uncheck Suppress temperature messages. If there are none, type the command M155 S5 and see if that changes anything.

As requested by @jcassel, the serial log (i.e. another systeminfo bundle after turning it on and duplicating the issue) will be useful for us as well.

First off thanks for helping!

Here are the temp interval settings and the serial.log.

Temperature Interval(Polling):
5s When printing or idle
2s When idle and a target temperature is set
Temperature interval (autoreport)
2s Autoreport interval to request from firmware

serial.log (60.4 KB)

So I set a temperature. I switched to the terminal tab. What do the temperature reports look like?
I'm assuming its the lines below: Send: M104 S180
Recv: ok

Thanks again for the help! I still haven't gotten a full grasp of how this all works. So you guys are awesome for providing support.

That looks like Creality's broken temperature reports, about which the FirmwareCheck plugin should have given your a warning and asked you to install a plugin that fixes things.

1 Like

Thanks that fixed it!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.