Additional Info - filament length vs volume. No weight in grams

What is the problem?

I only see weight in the file manager additional data section. Currently I see length in meters, but nothing in grams. I am not sure if this is something octoprint calculates or pulls from the gcode file and is somehow tagged by the slicer. I do not think this is a bug. I just do not understand. Sometimes I see a simple linear m or sometimes volume based on m/cm3

What did you already try to solve it?

I tried to search the forum to find others who may have asked the same question. I looked through the octoprint settings to see if there was an option to add filament weight to the additional info dropdown.

Have you tried running in safe mode?

No, I do not think this is a bug.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36
connectivity.connection_check: 192.168.92.1:53
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 914010112
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.7.3-20220120112925
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.8.6
printer.firmware: Marlin V1.0.2; Sprinter/grbl mashup for gen6
systeminfo.generated: 2022-10-28T11:35:18Z
systeminfo.generator: zipapi)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.8.6 on Raspberry Pi. 3b+, Makergear M2, Sliced with Prusa Slicer

You may have a look on this: