After Z-homing interruption, octoprint can't connect to printer

What is the problem?

Printer was z-homing with a crtouch, I reached for the nozzle to clear some loose filament fibers hanging off of it. In doing so, my hand bumped the crtouch probe so it stopped, then went for the slow press to verify. I stopped the print and the printer gave a "fail to home" error and requested a restart. After restarting, octoprint now "could not autodetect your printer" and "no serial port found"

The state of the printer on the octoprint server reads: "No more candidates to test, and no working port/baudrate combination detected."

What did you already try to solve it?

Restarted printer again.
Restarted octoprint.
Unplugged and plugged back in the printer to the raspberry pi.
Rebooted the raspberry pi.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (1.1 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.9.2
Octopi 0.18.0 on Raspberry pi 4
Ender 3 V2 with Jyers firmware

When you restart the printer, does it give a message on it's display?

Have you checked the CRTouch?

Nope, printer works fine on its own. CRTouch works fine as well.

Even if it ran before, but because it is a Creality printer try:

Tried it with and without the sd card, same result.
Also already had tape on the 5v pin so no luck there either

Looks like swapping my cord to the printer fixed it, not sure how but it did.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.