πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Artillery Hornet usb connection don't work

Hi Everybody!

What is the problem?
finally I have received my Raspberry Pi 4GB and I have installed the last stable version of OctoPrint.
Since the first start the webcam work immediatly but the usb connection with my Artillery Hornet don't work e the system do this error: "SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)."
Octoprint has automatically set these connection values:
Serial Port: / dev / ttyACM0
Baudrate: 115200

What did you already try to solve it?
I tried to restart the system, I tried disconnecting the webcam from the USB socket leaving only the 3d printer, I turned the 3d printer off and on again, I tried to swap the USB ports, I also tried to vary all the baudrate values but nothing changed.
I have change the USB cable.

Have you tried running in safe mode?
Yes

Did running in safe mode solve the problem?
No, I have same problem.

Systeminfo Bundle
You can download this in OctoPrint's System Information dialog ... no bundle, no support! )

octoprint-systeminfo-20220410165548.zip (48.8 KB)

Additional information about your setup
OctoPrint version, OctoPi version, printer, firmware, browser, operating system, .... as much data as possible

OctoPrint 1.7.3
OctoPi 0.18.0
Firmware: Marlin 2.0.7.2. It is the firmware received from the factory.
Browser: Mozilla Firefox 99.0; Chrome 100.0.4896.75, Brave 1.37.111
OS: Windows10Pro 21H2 64bit
I am using the original power supply.
Only the 3D printer is connected to the Raspberry

How I can resolve this problem?
Have any of you had a similar problem?
I have consulted the topics on the forum but they do not correspond exactly to my problem.
I attach the error screenshot.
Thank you in advance.
Neardj

Hello @neardj !

Maybe by accident you choosed the wrong subforum. I moved it.

So please, the following template asks for several information. Fill it in as good as possible.


What is the problem?

WRITE HERE

What did you already try to solve it?

WRITE HERE

Have you tried running in safe mode?

WRITE HERE

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support! )

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, .... as much data as possible

WRITE HERE

Thanks @Ewald_Ikemann I apologize for my mistake. I have arranged the post according to the template I hope I have compiled correctly.
Thanks

1 Like

OK, but:

I did it now. Sorry again! I'm a fool!

I update the topic.
I contacted Artillery support with the doubt that the USB connection was not working. They suggested that I try to connect the printer to a windows pc using the "Pronterface" software. With Pronterface the printer is controlled remotely.

What can be the communication problem with OctoPrint - OctoPi?

Was looking for a friend so havent tried the guide. But maybe this helps:

https://buildbee.com/printers/artillery-hornet/octoprint