Auto Home Failure

What is the problem?

I am using and Ender 3 Pro and Octoprint 1.8.7. Yesterday I was running a print that ran out of filament. This resulted in a jammed nozzle. I cleared the jam and set up to print the again and it failed the auto home with an M112 halt. I reset and tried again.. same thing. Eventually I determined that auto home only fails when the Raspberry Pi/Octoprint server is plugged in.'
I run a BLtouch and at first I thought it was a connection issue with the Bltouch. Perhaps a damaged cable, but soon found the Auto home only fails when connected to the Octoprint Server.

What did you already try to solve it?

I re-flashed Octopi in case I had a bad plugin or upgraded something that was causing the failure.
I replaced the SD card in the Ender 3
I replaced the USB cable.
None of these had an effect, other then having the USB unplugged. Auto home works then.
I have checked all the cables.
Checked the BLtouch.
Of Course searched the web but found nothing.

Have you tried running in safe mode?

When in safe mode I can auto home.

Systeminfo Bundle (38.3 KB)


I am running Marlin 2.0,6 with Octoprint 1.8.7
Also have the App on my phone.
Bltouch... Version 2.2

I can't tell you anything more. This machine has worked flawlessly since I first started using Octoprint.
I am stumped. It just started suddenly.

What ever Auto Home is...
I just know homing.

So it is one of the 3rd pary plugins.
You only have the Marlin EEPROM Editor installed.

The issue is with the printer. For it is Creality try with/without SD card in the printer's SD card slot and Put tape on the 5V pin - Why and how.

BTW: powercycling the Pi does not make things better. :wink:

Hey thanks for your input.
So first off Auto Home and Home are the same..Just how Marlin labels it this time around.
Yes Safe mode it does work. But will try again just to confirm. But I only have the one plugin so I could disable it. But surprised it would be a problem this is a fresh Octoprint install.
I have tape on the 5V for the USB and have tried with no SD card. The result is the same. It will not home with out an M112 stop with Octoprint connected.

I am going to replace the BLtouch as soon as I can. Going back to when the original fault occurred, it was right after a nozzle jam which meant I had to unmount the BLtouch while I pulled the print head apart and cleaned it up. It's not inconceivable that the cable to the BLtouch or the touch itself are damaged in some way as a result of the disassembly.

I will get it ordered this new week.
Thank you for your suggestions they are greatly appreciated.


Creality printers are known for quite quirky programmed firmware.

I agree.
This just started yesterday after a year. Weird.

Ok so I have determined that the issue is the Ender 3 firmware was corrupted. My gut tells me that some Octoprint upgrade I did damaged the code. I saw something about 1.19 or something on the Octoprint page and after that it stopped working. Now I just need to find Marlin 2.0.6 with BLtouch for an Ender 3.
Seems I lost my backup some how.
The hits just keep on coming. But I am closer now.

You may have a look here:

Configurations/config/examples/Creality at import-2.1.x · MarlinFirmware/Configurations · GitHub

Thank you for this.
So I went back to the beginning.
In safe mode it fails.
In standard mode it fails.
With all plugins disabled it fails.
It probes the center and on the second probe it raises up farther then it should and then M112.
Next I will replace the cable as I have confirmed it's not the probe itself as I have replaced it.

ok so its clearly something to do with this specific machine.
If I plug in a different Octoprint server from the machine next to it. Fails.
If Octoprint isn't plugged in it Homes just fine.
I replaced the Bltouch ..but no affect.
Starting to wonder if the USB port on the board is the issue yet I have control over the machine..I can move axis, heat it up cool it down but not home it.

Nah. OctoPrint doesn't do anything to the firmware. Also if you're running 2.0.6 you're probably using a 32bit board and most of them don't even support firmware flashing via usb - even if you wanted.

Ya I agree.
I confess I am stumped. The machine has worked for nearly a year with no issues then suddenly this problem. The good news is I flashed it with Marlin 2.1 something and it appears to be working.
I wish I understood why this happened but if it's working then wa hoooo.
I just need to tweak the board level and get back to printing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.