Automatic boot doesn't work

What is the problem?

I can run ~/OctoPrint/venv/bin/octoprint serve to start the octoprint UI, just can't make it start automatically on boot, it doesn't give an error, it says "Executing: /lib/systemd/systemd-sysv-install enable octoprint" but does nothing

What did you already try to solve it?

Tried following this guide link

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (42.2 KB)

Additional information about your setup

I'm running 1.7.3 (updated thanks to this community) on an Ubuntu desktop, couldn't find any RPis online under 100 bucks

Not sure how I missed the link Link

when and where does it say that?

It says it in the terminal when I run the command listed below
sudo systemctl enable octoprint.service

Nevermind, fixed it

And the issue was?

Not sure, I just ran the stuff from this guide, and it fixed my problem Setting up OctoPrint on Ubuntu 20.04 with Python 3 | Illuminated3D

1 Like

Did you remove everything from the previous attempt?
Just randomly mixing guides and not knowing what your doing is a dangerous combination:
Might work but could also have unpredictable consequences.

1 Like

And now I canโ€™t automatically boot up mjpeg streamer, says itโ€™s running but when i refresh octoprint UI, nothing, do I have to reboot for it to take effect?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.