BIG Serial Problems started since 1.6.0stable

What is the problem?

Serial communication is spotty and breaks down after only a few commands parsed. I lack a 2nd rpi or 422 board to rule either out. Here is output from octoprint terminal, only recently have these more descriptive errors occurred, before it just said won't connect due to error (duh). At same time I did update to stable I also put printer on it's side where no port was strained to add some springy feet. (I advise wire-tying all cables to compatible parts of frame whenever doing this.)

Unexpected error while connecting to serial port /dev/ttyUSB0, baudrate 115200 from hook default: SerialException: '[Errno 5] could not open port /dev/ttyUSB0: [Errno 5] Input/output error: '/dev/ttyUSB0'' @

What did you already try to solve it?

I swapped the USB cable for printer from one port to another. Safe mode of course and plenty of restarts. Replugged the micro-b connector several times and verified the port was still on PCB. I'm getting a v427 board for my printer monday so I'll be back..

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-logs (2).zip (312.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.6 stable, not sure. ender 3 pro with v422 32bit, marling bf 2.0.8, windows 10, cura. The USB cable I have used for programming ESPs without trouble.

If you're using an sd card in your printer - try it without one and vise versa.
There is a weird sd card related usb bug on some creality 32bit boards

And if that doesn't help share a system info bundle.

Since upgrading to 1.6.0stable, I am also getting serial issues. The printer is very jerky. Creality Ender3 pro - BTT-SKRmini E3 V2.0 running Marlin bugfix
It only started after upgrading to 1.6.0 since I pulled a print job previously printed just before upgrading. This one now is also showing the exact jerky behaviour. (2.7 MB)

2021-05-03 15:08:59,466 - octoprint.plugins.psucontrol - ERROR - Exception while writing GPIO line
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_psucontrol/", line 463, in turn_psu_on
KeyError: 'switch'

Likely because of that. What's your PSU Control config look like?

Actually do me a favor and just repost that bit into a new thread and reference this one.

Have the same behaviour. Could not print after update to 1.6.0. Is there a official bug report?

No, as so far no one has opened one and also so far all instances of this kind of issue were due to third party plugins. So test in safe mode, if the issue persists open a full bug report please.

Safe test mode is a life saver. It determined it immediately for me. Thanks @foosel

please ref the solution that worked for me here:

Solved for me also. Updated all plugins :slight_smile:

1 Like