Jerky printing since upgrading (OctoPrint1.6.0, PSU 1.0.5)

Jerky printing after upgrading. Not sure if its Octoprint 1.6.0 or PSU 1.0.4

on request referencing:

Printing is jerky even when recalling a print which was done just prior to these two upgrades.

I have not tried running safe mode

System Info Bundle can be found in the link posted above.
PSU settings copied below (if there is a better way, other than select copy text, please let me know):

Show warning dialog when powering off via toggle button.
GPIO Device

Pin numbers correspond to what is exposed by the GPIO device. Raspberry Pi Users: Use BCM numbering. See:

Switching Method

On/Off GPIO Pin
Enable switching with G-Code commands.
On G-Code Command
Off G-Code Command
Turn off when an unrecoverable firmware or communication error occurs.

Sensing Method

Sensing GPIO Pin

Polling Interval

Power On Options
Automatically turn PSU ON
Post On Delay
Post On GCode Script
Connect when powered on.
Turn on prior to printing after API upload

Power Off Options
Automatically turn PSU OFF when idle
Idle Timeout
Ignore Commands
Wait For Temperature
Pre Off GCode Script
Disconnect on power off.

Thanks. So while I do see that error about not being able to read or write to GPIO the logs aren't fresh and instead rolled over. Can you capture fresh logs by following Troubleshooting · kantlivelong/OctoPrint-PSUControl Wiki · GitHub ?

Here is the updated logs.
I have also included a short description of what I am doing with the GPIO below.:

BCM20 pin38 'Switching'

piconn<-- (input from PSU pluging)

# indicates PSU has been turned ON
# configured input set Pull Down to 0v while waiting GPIO.setup(20, GPIO.IN, pull_up_down=GPIO.PUD_DOWN)
# pin38 - to 1Kohm to pin40

#-->>>--(jumpered together)

BCM21 pin40

OctoPi_PSU--> (output to PSU plugin)

# OctoPi PSU-plugin switching is done on BCM21(5v sig) which is jumped to PiConn BCM20(pulldown)
# switching PSU (in this case we wait for it to go OFF for self shut down)
# configured in OctoPi_PSU plugin as BCM - 'GPIO 21'

BCM16 pin36 'Sensing'

piconn--> (output from piconn)

# confirms PSU is ON
# configured ouput set to LOW initially GPIO.setup(16, GPIO.OUT, initial=GPIO.LOW)
# pin36 to 1Kohm to pin32

#-->>--(jumpered together)

BCM12 pin32

OctoPi_PSU<-- (input from piconn)

# OctoPi PSU-plugin sense/bolt is done on BCM12(as FLOAT) which is jumped to PiConn BCM16(init LOW)
# Sensing of piconn state (turns on the electric bolt in OctoPi)
# configured in OctoPi_PSU plugin as BCM - 'GPIO 12' (2.7 MB)

2021-05-03 16:54:45,361 - octoprint.plugins.psucontrol - ERROR - Exception while setting up GPIO pin 12
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_psucontrol/", line 201, in configure_gpio
    pin = periphery.CdevGPIO(path=self.config['GPIODevice'], line=self.config['senseGPIOPin'], direction='in', bias=bias)
  File "/home/pi/oprint/lib/python3.7/site-packages/periphery/", line 496, in __init__
    self._open(path, line, direction, edge, bias, drive, inverted, label)
  File "/home/pi/oprint/lib/python3.7/site-packages/periphery/", line 547, in _open
    self._reopen(direction, edge, bias, drive, inverted)
  File "/home/pi/oprint/lib/python3.7/site-packages/periphery/", line 553, in _reopen
    raise GPIOError(None, "Line bias configuration not supported by kernel version {}.{}.".format(*KERNEL_VERSION))
periphery.gpio.GPIOError: [Errno None] Line bias configuration not supported by kernel version 5.4.

Huh I thought I had fixed that. You have two options:
A. Upgrade your kernel. Login via ssh and run sudo apt-get dist-upgrade. Be sure to make a backup first.
B. Install PSUControl-RPi.GPIO and configure PSUControl to use that.

I'd recommend trying A but nothing wrong with using B.


C: Try a new test build. :slight_smile:

Install in Plugin Manager:

Wow! Thank you. I will try “C.” To get things tested out. Then proceed onward to upgrading the kernel and so forth. But first, thank you for your super quick assistance. I am currently trying to recover from a vaccine shot and will have more time at the end of this week (travel/work/essential nonsense!)

1 Like

Short answer, installation and configuration of the PSU Control's sub Plug-in worked flawlessly. Printing is back to normal - smooth as before.

Plugin installed and configured.

I tried the kernel update first without success and have not tried option C. as originally planned (time constraints to test at the moment).