πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

BlueIris to OctoPrint Streaming

Camera model
MS LifeCam HD-5000 running on Blue Iris 5.5.6.21

What is the problem?
The Stream works as expected using http://{BlueIris IP}:{BlueIris Port}/mjpg/{camera short name}/video.mjpg

The snapshot URL TEST gives an error:
" Snapshot test failed Could not retrieve snapshot URL, please double check the URL"
using http://{BlueIris IP}:{BlueIris Port}/image/{camera short name}

I can see both the stream and the snapshot when entering the same 2 URLs directly in the browser.

I tried adding different modifiers to the url found in the blog post below.

I'm not sure what logs are useful in this circumstance...

Python 3.10.4
Build tools for Visual Studio 2022
OctoPrint 1.7.3

This is a windows install. I followed the guide at the link below.

Everything else seems to works as expected. I've successfully uploaded and printed via the web interface after install.

The OctoPrint instance is running on the same machine as the BlueIris instance.

My hypotheses is the codec being used by BlueIris is not compatible with the OctoPrint snapshot feature, but I haven't been able to find the required codec listed anywhere.

Thanks in advance for your help.

Hi

Is it just the picture when you use http://{BlueIris IP}:{BlueIris Port}/image/{camera short name} in the browser or is there also something like a background, a frame, a text etc.. ?

You could also try /admin?camera=x&snapshot Snapshot on camera x (short name) or /cam/{cam-short-name}/pos=100 Causes a snapshot image to be captured from the specified camera.

@PrintedWeezl

Ya its just the camera image, however, I do have an overlay (time and date) being added to the image by BlueIris. I've tried turning it off, but it doesn't fix the issue with the failed snapshot test.

I wasn't 100% sure what you were suggesting in the 2nd half of your post but I tried:
http://{BlueIris IP}:{BlueIris Port}/admin?camera=x&snapshot
http://{BlueIris IP}:{BlueIris Port}/admin?camera={camera short name}&snapshot
http://{BlueIris IP}:{BlueIris Port}/image/{camera short name}/admin?camera=x&snapshot
http://{BlueIris IP}:{BlueIris Port}/cam/{camera short name}/pos=100

All gave the same result as the original post.

Solved!

I had to add credentials to the end of the snapshot URL. For some reason the stream URL prompted me to sign in but the snapshot did not.

Final snapshot URL: http://{BI Server IP}:{BI Server Port}/image/{Short Camera Name}?user={username}&pw={password}

1 Like