Brio 4k works on the 2.0 black usb doesent work on the 3.0 blue usb. ( making the 4k useless ) ( works good on the 2.0 on 1920x1080 )

Camera model
Logitech Brio 4k
What is the problem?
Octoprint and octolapse do not see my webcam if I use it in the blue USB Ports and from what I know if you want to make a timelapse with 4k photos you need to make it go through the usb 3.0.
What did you already try to solve it?
Basically I tried to add the -y , modify the octopi.txt camera_http_webroot="./www-octopi"
anyway. I tested, everything works if I use the 2.0 USB, I tested it at a resolution of 1920x1080 and everything works. If I move the webcam to the other usb type I can still control the printer and all the other functions but the camera doesn't work.

I know this is a pretty specific issue and if I won't be able to make it to work as 4k I will work with it like this but I intend to make some 3d molds for my craft ( leatherworking ) and tutorials and the quality of the timelapse would be nice to be as good as the rest of the video. Any help or directions about what I should learn would be really appreciated. I do not have any programing skill and such, I just did what I saw and read in youtube instructional videos and on the official website ( Also I forgot to mention but maybe it matters, I run the system on a 64 gb card ). Thank you and happy new year!
Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

The latest version, just bought and downloaded everything yesterday.

Hey @Pavel! I found this thread on the raspberry Pi forums that may be of use to you:

Looks like something in the raspberry pi firmware broke it, there is a solution inside. Let us know if it works for you.

1 Like

Thank you very much! I will check it out, I hope I manage to implement the solution. I am a leather worker. This is my first project like this. I got a printer to make my molds for my masks and learned everything from scratch, but this it feels really hard for me. Anyway. I will keep you updated if I manage to solve the issue. For the moment I just keep it in the USB 2 raised the resolution because I do not care about streaming, I just want my timelapse and I think for a photo made at 3840x2160 once every 2-3 minutes or so it might suffice.

1 Like

I know this is a really stupid question, but. How do I get to write that code? If I connect the raspberry to a screen I get the octopi login stuff, I put the default account pi and raspberry as password and I have written the sudo command but nothing happens and I do not even know how to formulate this question so I can find a video on google :)).

You need to access the terminal of the OS, easiest done using SSH with OctoPi.

SSH using Windows 10 - Raspberry Pi Documentation

There's also pages for other OSes too, I'm on windows so that came up first.

1 Like

Thank you again! You are very helpful ! I hope it will work.