Camera stopped working after update/upgrade

Camera model

Raspberry Pi Camera Rev 1.3

What is the problem?

Yesterday I have run update/upgrade over SSH and the webcam stopped to work. I don't know where to look to provide more information.

What did you already try to solve it?

Nothing special

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (69.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version 1.9.2
OctoPi Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

Hi, apparently there is an issue after an upgrade,. More info here.
I have a Logitech c270 webcam, and it works great.

Darug2300: I have been redirected to create a new topic. You can se it in the topic you have linked :slight_smile:
But to provide more info, here are some messages in logs:
vcgencmd get_camera: supported=1 detected=1, libcamera interfaces=0
journalctl -u webcamd: Failed to start the OctoPi webcam daemon with the user specified config.

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file: /boot/octopi.txt
camera: raspi
usb options: -r 640x480 -f 10
raspi options: -x 640 -y 480 -fps 10
http options: -w ./www-octopi -n --listen

Explicitly USB device:

Found video devices:
Scan again in two minutes
/root/bin/webcamd: line 103: kill: (30376) - No such process


This is a known issue on OctoPi 0.18. The apt update/upgrade process upgrades the vcgencmd get_camera script so it also returns info about the new libcamera driver, but this unfortunately breaks compatibility with the setup in place on 0.18.

It only impacts when you have camera=raspi in your configuration file for the camera, if you set this to be camera=usb (or auto) it would work fine. The RPi cameras work fine (and have done for years) with the UVC ("usb") drivers. In OctoPi 1.0.0, the raspi mode was removed. In the 'new camera stack' image it has moved on to use the libcamera drivers now.

You can either switch to usb or auto in your config, or upgrade your OctoPi version.

1 Like

So if I understand correctly, the solution is just to change the /boot/octopi.txt to "auto" or "usb"? If so, I have tried, but none of the options helped.

Here is what really helped me:

  1. Backup
  2. Burn new image to the SD card, with the latest OctoPi
  3. Restore
  4. Changed settings in /boot/camera-streamer/libcamera.conf to lower settings (800x600)
    Stream is now working, snapshot not, but I don't need it

Well, after some time, the stream becomes unavailable again. So the solution above is not stable one

I have reverted back to my previous instance. Camera is not working, but what is interesting is that via OctoEverywhere! I can see camera stream :slight_smile:

Helped to me. Thanks

I've had the same issue after upgrading.
The camera was not detected by libcamera-hello --list-cameras but it was detected by vcgencmd get_camera.
It started working again when I disabled legacy camera in raspi-config > Interface.
Now, libcamera-hello --list-cameras detects it again, for some reason vcgencmd get_camera does not, but the stream works fine on OctoPrint dashboard.

Hello, i have the issue that the camera is not working, it has worked the first time i plugged it but now it doesn't work, at the boot the red led blink once, than another time, then nothing, i've read some posts and tried some things, then flashed SD, installed the last octopi (new camera stack) as suggested in this post.
Camera is not working, if i do:
vcgencmd get_camera
supported=0 detected=0, libcamera interfaces=0

if i do
libcamera-hello --list-cameras
Available cameras

0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
Modes: 'SGBRG10_CSI2P' : 640x480 [30.00 fps - (0, 0)/0x0 crop]
1296x972 [30.00 fps - (0, 0)/0x0 crop]
1920x1080 [30.00 fps - (0, 0)/0x0 crop]
2592x1944 [30.00 fps - (0, 0)/0x0 crop]

any suggestion?