Cannot connect printer after 1.4.2

What is the problem?

Works ok on 1.4.1. Just upgraded to 1.4.2 and stop to connect to printer.

What did you already try to solve it?

Tried reboot both octopi and printer and diff bitrate but not working.

Complete Logs

2020-08-06 16:04:58,442 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Detecting serial connection"
2020-08-06 16:04:58,453 - octoprint.util.comm - INFO - Serial detection: Performing autodetection with 7 port/baudrate candidates: /dev/ttyUSB0@38400, /dev/ttyUSB0@115200, /dev/ttyUSB0@250000, /dev/ttyUSB0@230400, /dev/ttyUSB0@57600, /dev/ttyUSB0@19200, /dev/ttyUSB0@9600
2020-08-06 16:04:58,454 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 38400
2020-08-06 16:04:58,457 - octoprint.util.comm - INFO - Connecting to port /dev/ttyUSB0, baudrate 38400
2020-08-06 16:04:58,540 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:04:58,545 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:00,143 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.00ms
2020-08-06 16:05:00,558 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:00,562 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:02,144 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.22ms
2020-08-06 16:05:02,565 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:02,572 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:04,147 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 11.91ms
2020-08-06 16:05:04,579 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 115200
2020-08-06 16:05:04,589 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:04,600 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:06,143 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.50ms
2020-08-06 16:05:06,600 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:06,607 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:08,148 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 11.97ms
2020-08-06 16:05:08,609 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:08,621 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:10,144 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 12.86ms
2020-08-06 16:05:10,621 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 250000
2020-08-06 16:05:10,630 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:10,642 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:12,145 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.14ms
2020-08-06 16:05:12,648 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:12,662 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:14,149 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 12.15ms
2020-08-06 16:05:14,666 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:14,685 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:16,154 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 19.78ms
2020-08-06 16:05:16,681 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 230400
2020-08-06 16:05:16,687 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:16,701 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:18,149 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 12.01ms
2020-08-06 16:05:18,704 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:18,716 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:20,145 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 14.27ms
2020-08-06 16:05:20,717 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:20,732 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:22,148 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 15.31ms
2020-08-06 16:05:22,734 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 57600
2020-08-06 16:05:22,749 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:22,756 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:24,146 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.27ms
2020-08-06 16:05:24,758 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:24,764 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:26,145 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.89ms
2020-08-06 16:05:26,767 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:26,780 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:28,146 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.67ms
2020-08-06 16:05:28,783 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 19200
2020-08-06 16:05:28,798 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:28,805 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:30,145 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.28ms
2020-08-06 16:05:30,805 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:30,811 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:32,153 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.20ms
2020-08-06 16:05:32,818 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:32,830 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:34,152 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 13.07ms
2020-08-06 16:05:34,832 - octoprint.util.comm - INFO - Serial detection: Trying port /dev/ttyUSB0, baudrate 9600
2020-08-06 16:05:34,837 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2020-08-06 16:05:34,854 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:36,148 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 15.25ms
2020-08-06 16:05:36,861 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2020-08-06 16:05:36,872 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:38,154 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 14.57ms
2020-08-06 16:05:38,874 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2020-08-06 16:05:38,888 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-08-06 16:05:40,153 - tornado.access - WARNING - 409 GET /api/printer (::ffff:192.168.2.44) 14.67ms
2020-08-06 16:05:40,891 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
2020-08-06 16:05:40,921 - octoprint.plugins.excluderegion - INFO - Printing stopped: event=Error
2020-08-06 16:05:40,926 - octoprint.util.comm - INFO - Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"
2020-08-06 16:05:40,942 - octoprint.plugins.action_command_notification - INFO -

WRITE HERE

Additional information about your setup

Marlin 2.0.5, CR-10 v2

WRITE HERE

1 Like

Whatever this is, it has nothing to do with the update from 1.4.1 to 1.4.2 - I didn't touch anything even remotely related to the printer communication, 1.4.2 only touched the plugin manager and the watched folder.

See the changed files in the diff: https://github.com/OctoPrint/OctoPrint/compare/1.4.1...1.4.2

@Ludovic_Dome

Can you get connection with pronterface to the printer?

Thanks for response. :slight_smile:

What's the best way to rollback to 1.4.1? I want to quickly give it a try to back to previous status. Touched nothing but upgrade that's why my first hypothesis is on upgrading.

Use this URL in the Plugin Manager > Get More > ...from URL.

https://github.com/OctoPrint/OctoPrint/archive/1.4.1.zip

1 Like

Thank you!

Just be aware that if you all just roll back instead of working with me to identify and solve this issue, it will never be fixed as I cannot reproduce it myself :woman_shrugging:t2:

I just upgraded to 1.4.2 and I am having the same issue.

Edit: So here is an odd thing. I disconnected my z end stop and it started working. So I guess it's a hardware issue.

I've had the same problem after updating to 1.4.2, for me the auto detection was the cause (serial port or baudrate set to AUTO). I'm guessing that the update set the port to AUTO for me, and I had set it manually before.

I noticed that connecting manually to my Prusa MK3S takes quite long (a minute or so, see logs (24.7 KB)), is it possible that the auto detection timeout of 2s isn't long enough, causing it to fail?

I have exactly the same issue. I upgraded from 1.4.0 directly to 1.4.2 and after this I can't connect to my printer with the Auto setting in baudrate and serial port. After chaning the baudrate manually to 250000 and the serial port to /dev/ttyUSB0 the connection to my printer was established.

So with this version 1.4.2 there is a problem with the AUTO baudrate-setting and the AUTO serial port setting.

I use a raspy 1 here with an anycubic i3 Mega printer.
I hope this helps to solve this issue.

Thanks for octoprint :slight_smile:

Greetings from Germany
Sebastian .

1 Like

So where is the issue?
When you know where to set them manually, just do it.

Solving an issue usually needs more, like logs...

new to this but updating the artillery sw1`s pi3b and octoprint creates for me an issue where its now totally refusing to connect, with my limited experience ive tried changing a few things as above and nope nothing, thankfully ive not tried it with the other three printers - cr10 mini plus a pair ender 3 which are as normal connecting without issue so at this point in time none of the others will be getting this update, thankfully the sw1 has usb stick access as well as tf card so im not semi stuck, ive tried also the obvious - the cables

Just to help understand that there does seem to a pattern with this issue and the 1.4.2 upgrade, I had the same thing happen. No problems just prior to upgrading, then this, immediately after the upgrade:

Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

I looked at the changed files, and as @foosel pointed out, this upgrade shouldn't affect that. So, my assumption was it was an upgraded and/or incompatible plugin. I disabled all third-party plugins I had:

  • Bed Visualizer (0.1.14)
  • DisplayLayerProgress Plugin (1.23.0)
  • PrintTimeGenius Plugin (2.2.5)

No change. So, I completely uninstalled and cleaned up data for those plugins. Rebooted - no change.

I then disabled all bundled plugins, rebooted, still no change.

I SSH'd into the Pi and ran:

dmesg | grep tty

To make sure the serial port (ttyUSB0) showed up. Sure enough - it did NOT.

Here's the thing. I use a modified USB cable that prevents the Pi from powering my Creality controller through the USB port. (It is a quirk of the model that, so long as the USB port on the printer's controller, the screen backlight will stay lit.)

Swapped out the USB cable for an unmodified one (i.e. +5v, Gnd, D+, D1). Fixed it straight away.

However, as a software developer myself, I'm not satisfied with that solution. This is clearly something at the OS level since Linux didn't recognize the port. I can understand that. What I don't understand is why it had no problem before the 1.4.2 upgrade, but did immediately afterward.

When I get a minute, I'll dig deeper to see if I can't sort it out. For now, everything works great, using the regular data cable.

But, for anyone experiencing this problem, I would suggest running dmesg, as I did above, and see if your port shows up there. If not, the problem isn't with Octoprint - at least not directly. I would be curious, however, if rolling back to an earlier version corrects the problem. I'm betting not, but that would be interesting.

1 Like

Same issue here. No issues until I upgraded to 1.4.2 this morning.

Then the following error

Changing monitoring state from "Offline" to "Detecting serial connection" Performing autodetection with 0 port/baudrate candidates: Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected." Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

I did rollback to 1.4.1 immediately and nothing changed. Have also rebooted octoprint into safe mode with no change.

I only have a couple plugins so I didn't even bother going through them

I ran dmesg | grep tty

and got the following feedback

pi@octopi:~ $ dmesg | grep tty [ 0.000000] Kernel command line: coherent_pool=1M bcm2708_fb.fbwidth=656 bcm2 708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x1ec00000 vc_mem.mem_si ze=0x20000000 console=ttyAMA0,115200 console=tty1 root=PARTUUID=6c586e13-02 roo tfstype=ext4 elevator=deadline fsck.repair=yes rootwait [ 0.001260] console [tty1] enabled [ 1.041359] 20201000.serial: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2 [ 1.936436] console [ttyAMA0] enabled [ 6.768034] systemd[1]: Created slice system-getty.slice.

I also was using a modified usb cable for my cr10 v2 for the same reason. I switched back to an intact one just now and no change.

Still no connection for me.

I'm willing to work with the developer to debug as I have no problem just printing from sd card for now

My hunch (unproven) is that the upgrade to 1.4.2 updates something in Linux that prevents it from recognizing ttyUSBn for whatever reason. So, rolling back to 1.4.1 wouldn't fix it, since it has nothing to do, directly, with OctoPrint. I haven't had a chance to dig into what system changes might have sparked the issue.

But, I'm really surprised that swapping cables didn't do the trick. Even after rebooting?

Not really the case - all OctoPrint does, is install the new version as a python package - it has no way to touch the underlying system

The most common reason for issues after updates is corruption. Try (if you're using OctoPi) running ~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint to fully reinstall it.

That's not entirely true. It may be that it does not touch the underlying system, but it is not true that is has no way of doing so. We've done a lot of Python development, and run into this more often than we should. It usually has to do with a dependency of a dependency of a dependency, etc. that causes the problem.

OctoPrint, itself, is not causing this. But, the act of updating is. I am not seeing any dependency that is obviously the problem, either. (Haven't looked into RSA and itsdangerous, but I wouldn't suspect these first.) But, here's what I do know:

I restored a snapshot of my Pi taken back in April (1.4.0). Everything worked, as it did in April. I then did nothing but update to 1.4.2, and the ttyUSBn was no longer recognized. Rolled back to 1.4.0 and 1.4.1 to no effect.

Also, the failure to mount ttyUSBn isn't even an OctoPrint issue. The OS does not recognize the serial port, whether OctoPrint is running or even installed. It does, before upgrading, it doesn't after upgrading - confirmed twice.

I honestly don't think there is anything for the developer to do, here, but it is a reproducible issue that seems to affect some setups in a fairly consistent way. Since I am able to reproduce it, I'll look at it more, when I have time. Should be pretty easy, at this point, to see exactly what is different after the upgrade.

trying the octopi force reinstall now. I've got nothing to lose really. Didn't have any significant plugins installed. was just happy to print and monitor without running outside to the shop all the time. I'll update if i make any progress

nope no change

Here's more info. When I first installed octoprint and octopi with my new printer I originally worked fine, then I installed a couple plugins and it broke. Giving me the "failed to autodetect serial port error" I can't remember how I fixed it but it involved some commands and it all was working fine for a couple months. Fast forward to today and it will no longer connect with nothing changed except the update.

So I rebooted my pi with my original sd card image from a couple months back and immediately got the failed to autodetect serial port error. Not sure what version it was but maybe 1.3.something.

I did nothing except update octoprint to 1.4.2. Now immediately after the update its this error again.

Maybe that helps, maybe it doesn't...maybe it will help somebody who stumbles across this down the road. ANyways I'll keep updating this thread if i get it fixed