Cannot connect to Octoprint on a BIQU BX

I installed a Raspberry Pi 4b on my BIQU BX printer, formatted the SD card with Raspberry Pi Imager and OctoBTT_Octopi.img wich worked fine, added the specific entry for the BIQU BX in the octopi-wpa-supplicant.txt and config.txt files.
When I start the printer octoprint seems to start ok and stops while asking for username and password but give a logging incorrect error if I try to login directly on the pi.
If I connect with a Web Browser it accept my name and password but return " State: **Offline after error
No more candidates to test, and no working port/baudrate combination detected." when I click on the connect button.
I have looked arround for a hint, changed the USB cable between the pi and and the BIQU board but without any succes, very frustrating.
Does anyone have a solution ?
Thank you in advance for your help.

The username and password to get in to the command line are different from the web UI. By default it is username pi and password raspberry, unless wherever you downloaded the image from changed it. Given BTTs track record here, I'd like to have a look... Do you have a link to where you got it from?

Check some of the troubleshooting steps here for more - running lsusb to see if the printer is showing up as a USB device and dmesg after plugging in the device to see if there's any useful info.

I finally got to connect using PuTTY with pi and the corect password.
For the installation I got the OctoBTT_Octopi.img from GitHub - bigtreetech/OctoBTT: OctoBTT
For the connection between the Rasperry Pi and the BIQU BX board I used the cable provided by BIQU. I tried other USB cables without success.

Running the dmeg command I get :
[ 678.805873] usb 1-1.2: USB disconnect, device number 3
[ 681.749896] usb 1-1.4: new full-speed USB device number 4 using xhci_hcd
[ 681.884184] usb 1-1.4: New USB device found, idVendor=1a86, idProduct=e5e3, bcdDevice= 0.00
[ 681.884204] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 681.884221] usb 1-1.4: Product: USB2IIC_CTP_CONTROL
[ 681.884237] usb 1-1.4: Manufacturer:
[ 681.928496] input: USB2IIC_CTP_CONTROL as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:1A86:E5E3.0002/input/input2
[ 681.932144] hid-multitouch 0003:1A86:E5E3.0002: input,hidraw0: USB HID v1.00 Device [ USB2IIC_CTP_CONTROL] on usb-0000:01:00.0-1.4/input0
[ 715.960515] usb 1-1.4: USB disconnect, device number 4
[ 718.788333] usb 1-1.3: new full-speed USB device number 5 using xhci_hcd
[ 718.922758] usb 1-1.3: New USB device found, idVendor=1a86, idProduct=e5e3, bcdDevice= 0.00
[ 718.922777] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 718.922794] usb 1-1.3: Product: USB2IIC_CTP_CONTROL
[ 718.922810] usb 1-1.3: Manufacturer:

I can honestly not recommend using any image but the official one. It's impossible to say what was modified, and last time I checked there were also some security issues with the octobtt one that I reported to them but never heard if they got fixed or not.

Forget about the display for now, flash stock OctoPi and let's see of that works with your printer first. Then we can start working on added stuff like a touchscreen and stuff.

I found ( · GitHub) that a second USB cable was needed between the pi and the printer board, the USB cable between the pi and the display board is not enough. With this second USB connection I can now connect to the printer from a Web browser even thou the printer display is still in terminal mode.
It seems that further installation in the pi is needed in order to have a complete integration.
I will get another sd card to make some trials and report the result in some time.
In any case, thank you for your advice.

Finally I got the connection to the touch screen by installing OctoDash (GitHub - UnchartedBull/OctoDash: OctoDash is a simple, but beautiful dashboard for OctoPrint.).
Thank's for your help :grinning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.