Cannot update from 1.4.0 to 1.6.1

What is the problem?

Updating from 1.4.0 to 1.6.1 fails. Attempts made though web interface and manually through SSH terminal. Error message pop up:

The update did not finish successfully. Please consult `octoprint.log` and `plugin_softwareupdate_console.log` for details.

What did you already try to solve it?

Connected to OctoPi through SSH terminal and ran the following code:

apt get update 
apt get upgrade 
~/oprint/bin/pip install -U octoprint

This did not complete succefully either, but Octoprint continued to function after restarting with

sudo service octoprint restart

Have you tried running in safe mode?

Yes. Resulted in failure with the same error message pop up

Did running in safe mode solve the problem?

No. Did not solve problem.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Currently on version 1.4.0 (Does not provide Systeminfo Bundle). Logs attached below.

octoprint.log (287.6 KB)
plugin_softwareupdate_console.log (267.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version 1.4.0
OctoPi Version: 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1

All normal functions (printing, timelapse etc. are working as expected)
Printer: Prusa MK3S clone
Printer Firmware: 3.10.0
Browser: Google Chrome, Version 90.0.4430.212 (official build)
OS: Windows 10 - 64 bit

All other plugins updated without problems, only Octoprint returned an error message

Ah, the good old rogue logging module installed by some plugin strikes again:

edit Now also on the FAQ:

@kthayyi2 next time, please also include how the manual install through SSH failed. You thankfully also included your plugin_softwareupdate_console.log which I could see the actual error message in, otherwise this would have been a case of another roundtrip just to get enough info from you to help you.


Thank you so much for such a quick reply! Your solution worked!

Yes, I did have print time genius installed.
I have now uninstalled logging (via SSH terminal)
I then restarted my OctoPrint server (via SSH terminal)
Then, through the web interface, I tried updating OctoPrint to 1.6.1 and it worked!

Once again thank your for all your time and effort into OctoPrint and OctoPi!