Cannot update from 1.6.1 to 1.7.3

What is the problem?

As per title.
pastebin log

What did you already try to solve it?

Tried installing the fix plugin for Genius plugin. Tried removing Genius plugin.

Have you tried running in safe mode?

No

Systeminfo Bundle

octoprint-systeminfo-20231011191714.zip (57.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.6.1 Python 2.7.16 OctoPi 0.17.0

I see that you installed the plugin, but it seems like it didn't do anything. At least there is no output in the logs.

Please try it manually

If you need help with ssh connection, follow this guide

username: pi
password: raspberry

I will also note that this issue upgrading only occurs on old Python 2 installs. 1.7.3 is nowhere near the latest OctoPrint version because you are running on an old, now unsupported OS setup. You should upgrade to make sure that you are using Python 3.

1 Like

I am unable to login to ssh as the user/pass is not being accepted.

Which ones did you use?

Standard credentials for OctoPi are pi/raspberry - as long you did not change them.

I am using pi/raspberry
I do not recall if they were ever changed, but I doubt it.

I hope this way still works

If it doesn't work try this

But if I were you I would backup OctoPrint via the backup and restore feature and just flash a fresh OctoPi version onto the sd card. Your OctoPi version is pretty old and outdated.