Cannot update plugins, logs don't appear to show error

What is the problem?

I cannot update any plugins through the plugin manager. When I try I get the following error:

Update failed!

The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details.

To my knowledge I haven't made any changes to the system that would have resulted in this, though I update plugins and software whenever prompted. This started about a month ago.

plugin_softwareupdate_console log
octoprint-logs (1).zip (810.4 KB)

octoprint log
octoprint-logs (3).zip (188.4 KB)

What did you already try to solve it?

I've tried:

  • Restarting and restarting in safe mode.
  • Allowing automatic updates to pip.
  • Force check for updates
  • Googling the softwareupdate_console log's most recent entries but nothing is clearly an error to me.

Have you tried running in safe mode?

Yes, no change.

Did running in safe mode solve the problem?


Systeminfo Bundle (81.6 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint V 1.6.1, Anycubic Mega S, Mozilla/5.0, Pi OS: Linux2


the logs show plenty of Error actually.

octoprint.util.pip - ERROR - Error while trying to run command /home/pi/oprint/bin/python2 -m pip --disable-pip-version-check install [URL to *plugin]

UnboundLocalError: local variable 'p' referenced before assignment

Your system still runs python2 and that is EOL.
Something very basic (pip install) doesn't run any more.

Apparently your system is ripe for a major upgrade.
Have a look at Upgrade your OctoPrint install to Python 3!

If I found myself in that situation, I would

  • backup the current octoPrint - and all other things you may have customized on that box. If your lazy/paranoid, saving an image of the entire sd-card on another computer should have you covered. Just mount it once to verify it does in fact work. Or even easier, put the old sd-card somewhere safe and use a new card for the next step.
  • flash the sd-card with the current octopi
  • restore from backup
1 Like

To clarify, using Python 2 is not the reason you can't update any more. There seems to be something broken in your environment/pip install. The benefits of upgrading to Python 3 would be twofold in this case specifically:

  • The script automatically rebuilds your virtual environment to use Python 3, which would probably fix this issue.
  • You would be using Py3, which is going to be necessary going forward & already is for a lot of new plugins.
1 Like

In my view it's just not worth to invest time and efforts to fix an install centered on python2 when this is EOL. Besides, other than python many software packages will gt an update and security fixes.

Agreed, I just don't want people to come around here trying to say we deliberately broke things ok Python 2... It wouldn't surprise me if we get something like that at some point.

Thanks everyone for their help. I’m not the most technically adept 3D printer, so I really appreciate people finding the issue I couldn’t.

I’ll update and let you all know the result.

Flashing the new version solved all my problems. Thanks, everyone!