Cannot Update to 1.7.3

What is the problem?

Cannot update to OctoPrint to 1.7.3
Each time I try I get the following message Update failed!

The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details.

What did you already try to solve it?

I have tried in Safe Mode and also updated the pi in ssh using ```
sudo apt update and sudo apt upgrade followed by sudo apt clean and sudo reboot. I have also run
I have these details in system info
browser.user_agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.109 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true : true
connectivity.resolution_check :
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1400
env.hardware.ram : 917016576
env.os.bits : 32 : linux
env.os.platform : linux2
env.plugins.pi_support.model : Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version : 0.16.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 19.0.1
env.python.version : 2.7.13
env.python.virtualenv : true
octoprint.safe_mode : true
octoprint.version : 1.6.1
systeminfo.generator : systemapi

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
I have downloaded the systeminfobundle but don't know how to upload it here.

Thanks for any help with this.

Additional information about your setup

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.109 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 917016576
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.16.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.0.1
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.6.1
systeminfo.generator: systemapi


The button is here:

Here is the system info file

Thanks Charlie (68.9 KB)

Your OctoPrint install is still running on Python 2, it should be upgraded to use Python 3 as soon as possible. OctoPrint 1.8.0 will no longer support Python 2 as it has been end of life for 2 years now.

Ok I have updated python to 3.8 and will try again

If not I'll try a new octopi download and start from scratch

That still had errors, So I have made a note of my plugins and settings and I am re-installing the new octopi version with the 1.73 octoprint built in. Thanks for your suggestions Charlie

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.