Cannot upgrade from 1.6.1 to 1.7.3

What is the problem?

Cannot upgrade from 1.6.1 to 1.7.3

Installing build dependencies: finished with status 'done'
Getting requirements to build wheel: started
ERROR: Command errored out with exit status 1:
command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/ get_requires_for_build_wheel /tmp/tmpDtHQZa
cwd: /tmp/pip-install-wRu6sX/psutil
Complete output (10 lines):
Traceback (most recent call last):
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/", line 280, in
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/", line 263, in main
json_out['return_val'] = hook(**hook_input['kwargs'])
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/", line 108, in get_requires_for_build_wheel
backend = _build_backend()
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/", line 99, in _build_backend
obj = getattr(obj, path_part)
AttributeError: 'module' object has no attribute 'legacy'

ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip/_vendor/pep517/ get_requires_for_build_wheel /tmp/tmpDtHQZa Check the logs for full command output.
Getting requirements to build wheel: finished with status 'error'
The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details.


What did you already try to solve it?

tried to upgrade in safe mode
updated pip version
installed the cleanup_loggin plugin

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint.log (132.1 KB)
plugin_softwareupdate_console.log (449.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
OctoPrint 1.6.1
Python 2.7.13
OctoPi 0.16.0
Marlin 2.0

I would recommend upgrading to an OS that supports Python 3 first, and as part of that process you would end up with a new environment that will not have issues updating. Old environments are more prone to issues the longer they are left. OctoPrint 1.8.x+ does not support Python 2.7 at all, so you would have to upgrade to use Python 3 if you wanted to upgrade further anyway.

ok ended up just doing a backup full reinstall and restore

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.