Can't connect to my Ender 3 via OctoPrint

What is the problem?

I can't connect to the printer using OctoPrint. Getting this error:
Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?
I tried manually selecting all baudrates, also tried to update octo and restarted both the pi and the printer.

I also tried running lsusb and I saw that there is no change once the printer is connected with the USB cable and once I disconnect it.

I also removed the tape which i put on the USB cable (in order to resolve the 5v problem), but still can't connect any new device. I will try with a new USB cable later today

Logs (syslog, dmesg, ... no logs, no support)
octoprint log -

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Ender 3 PRO
This is the first time I'm connecting it, I'm on the same network, the Pi is a bit further from the router but I doubt this would be the problem.

Hello @Hristiyan_Hristov!

You have this in your log:

2020-09-03 21:18:31,811 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

You also might have a flash icon at the navbar: image

Restart the Pi without the printer connected. If that icon does not appear try this:

If it still appears, you should look for a better power supply (not charger)

1 Like

Once I put the tape on the USB connector the problem with the undervoltage disappeared.

I just tried one more USB cable and it's working now. Thanks a lot!

1 Like

Great! could you please do this:

Did it, thanks !

1 Like

This tape trick did not help on my Ender-3 Pro with the same "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)". I tried two different cables.