Cant detect printer after taping +5V in USB plug

What is the problem?

To try to fix an issue with my Raspberry Pi Zero 2/OctoPi powering my Ender 3 Pro while its off, I'm trying to tape the +5V pin on the USB cable according to these instructions: Put tape on the 5V pin - Why and how

However, after doing so I get an error in OctoPrint that it can't find the serial port of the printer.

It works fine without the tape, other than the issue with power the printer while its off

What did you already try to solve it?

Tried safe mode. Tried moving the tape to each of the 4 pins in the USB to make sure I wasn't taping the wrong one. Tried different USB ports on the Raspberry Pi Zero 2

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

octoprint-systeminfo-20220919151111.zip (470.9 KB)

Hello @HandyMan !

I assume you powered printer.

It's quite tricky to get only the +5V rails covered out of the 5 rails on a micro USB port.

1 Like

Hi!

Yes, I powered the printer through its normal power supply.

I am using this Micro USB > USB hub: https://www.amazon.com/gp/product/B01HYJLZH6/ref=ppx_yo_dt_b_search_asin_image?ie=UTF8&psc=1

so I'm taping a normal sized USB cable connector that is then being plugged into the hub, and the hub is plugged into the Pi Zero normally with no tape on the Micro USB

Sorry I should have been more clear in my original post!

1 Like

Make sure you are only covering the + pin. Even the type A connector can be tricky for getting the tape only on the 1 pin. When you don't tape the pin and it sees the printer, is that still with the hub? If not try that with the hub and see if it still sees the printer.
Is anything else plugged into the hub? If not just use the micro-USB to USB-A adaptor for the Pi.

1 Like

5ft24,

Thanks for the tips.

When I don't tape the pin and it works, it was still using the hub. I also have my webcam using the hub.

I've tried taping a couple different times with different thickness of strips of electrical tape, and inspected closely to make sure its only covering the one pin.

I'm wondering if the hub might be the problem... maybe if the hub doesn't see the +5v it just doesn't activate that port or something? If Raspberry Pi's were all sold out I'd just order a full size one to see if that would fix it.

I would buy a micro USB male to micro USB female extension cable (like this one), carefully strip the insulation off, and cut the 5V wire (which is hopefully red).

Some printers don't have their own 5V regulator and steal the 5V from the USB line. In that case you cannot cut the 5V line.

1 Like

I figured it out! and its my own stupidity. I would always re-start the Raspberry Pi as a possible trouble shooting method, but never considered restarting the printer for some reason... and that solved the problem!

Not sure if its how OctoPrint works, or the Ender 3 pro, or the combination of the two, but once OctoPrint has connected to the printer, if I unplug and plug the USB back in (like I did every time I tried the tape method) it won't reconnect. I have to restart the printer for it to work.

Thanks again to everyone for your advice. Sorry to waste your time with my stupid mistake! I never thought I would be the quintessential tech support request that just needed to restart the machine! Ha!