Can't get RaspPi camera version 1.3 to work with new 1.9.1 Octoprint

Camera model

Raspberry Pi 1.3

What is the problem?

I have been using Octoprint for years. As soon as I installed the new 1.9.0 update, I started having all sorts of problems with my printer, the CR touch sensor doesn't work, Prints stopping, the screen acts weird. I have found that a few plugins seem to be the problem. I disabled a bunch of them. Specifically, the Classic Webcam plugin seems to be a major issue. A few other plugins seem to be at issue as well.

I have decided to do a fresh clean install of the newest 1.9.1 with the camera stack. I can't get the webcam to work. I am sure I am doing something wrong, but can't figure it out. The camera is fine, if I put the old SD Card in and boot up (and enable the classic webcam plugin) the webcam in Octoprint works fine (but printer is all screwy again.

Any ideas on how I can configure my fresh install of 1.9.1 so the camera works?

Thank you in advance.

What did you already try to solve it?

See above

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

Ender 3V2 with CR Touch. I am using Mriscoc's professional firmware. RPi 3B+, 32GB Kingston card


This is critically important for us to understand what is going on in your OctoPrint instance. There's no way I can figure out your problem just from knowing the camera is not working, we need this info.

Hi Charlie, thanks and I will post this info. But before I take the time, can you tell me what OctoPrint's official stance is? Are version 1 and version 2 Raspberry Pi cameras officially supported with version 1.9.1?

I am having a similar issue.
@AndySharp It would be nice for you to take the time to provide all information asked, as it will help the developers. All versions of the Raspberry Pi Webcam should be supported, there is no documentation advising they would not be. It only takes 20 seconds to get the Sytem Bundle file. (99.9 KB)

I have uploaded my system bundle zip file to this comment

Edit: Additional note. I am getting a timeout error when starting the WebcamD service. I noticed the red LED on the PiCam lights for 2 seconds on reboot then goes off, so I tried manually starting the service. I am using OctoPi, with Octoprint 1.9.1 on a Raspberry Pi 3B+

pi@octoprint:~ $ sudo service webcamd start
Job for webcamd.service failed because a timeout was exceeded.
See "systemctl status webcamd.service" and "journalctl -xe" for details.

pi@octoprint:~ $ sudo systemctl status webcamd.service
● webcamd.service - the OctoPi webcam daemon with the user specified config
   Loaded: loaded (/etc/systemd/system/webcamd.service; enabled; vendor preset:
   Active: activating (start) since Sat 2023-07-08 15:10:31 AEST; 1min 14s ago
Cntrl PID: 1423 (webcamd)
    Tasks: 2 (limit: 1935)
   CGroup: /system.slice/webcamd.service
           β”œβ”€1423 /bin/bash /root/bin/webcamd
           └─1434 sleep 120

Jul 08 15:10:31 octoprint systemd[1]: Starting the OctoPi webcam daemon with the
lines 1-10/10 (END)

pi@octoprint:~ $ sudo journalctl -xe
-- Automatic restarting of the unit webcamd.service has been scheduled, as the r
-- the configured Restart= setting for the unit.
Jul 08 15:12:02 octoprint systemd[1]: Stopped the OctoPi webcam daemon with the
-- Subject: A stop job for unit webcamd.service has finished
-- Defined-By: systemd
-- Support:
-- A stop job for unit webcamd.service has finished.
-- The job identifier is 1384 and the job result is done.
Jul 08 15:12:02 octoprint systemd[1]: Starting the OctoPi webcam daemon with the
-- Subject: A start job for unit webcamd.service has begun execution
-- Defined-By: systemd
-- Support:
-- A start job for unit webcamd.service has begun execution.
-- The job identifier is 1384.
Jul 08 15:12:03 octoprint haproxy[597]: ::ffff: [08/Jul/2023:1
Jul 08 15:12:03 octoprint haproxy[597]: ::ffff: [08/Jul/2023:1
Jul 08 15:12:25 octoprint sudo[1468]:       pi : TTY=pts/0 ; PWD=/home/pi ; USER
Jul 08 15:12:25 octoprint sudo[1468]: pam_unix(sudo:session): session opened for
lines 2728-2750/2750 (END)

I decided to just buy a new Arducam. Problem solved. (I posted in several places and no one responded at all (yes, in this forum there was a response asking for the bundle. But I already decided to just move on.)

Update: I purchased the Arducam IMX708 fixed focus camera. It did work great with minimal fuss inside Octoprint 1.9.1. But since it was fixed focus, it was blurry. So, I returned it and got the Arducam IMX519 autofocus. The camera works fine inside OctoPi and on the RasPi 3B+. I can grab screen shots and catch a stream for X seconds. But I cannot get it to run inside OctoPrint 1.9.1. I have created a new post specifically addressing this, but as yet no answers. :frowning:

Well, after getting a Ph.D. in webcams and the new camera stack in Octoprint 1.9.1, I fixed this issue. As mentioned, I upgraded my camera, but I wanted to see if I could get this one (v1.3) working. Did it!

Really very simple:

  1. Disable legacy camera in Raspi-Config
  2. sudo nano /boot/config.txt
  3. Find the line: camera_auto_detect=1, add the following line underneath that one:
  4. Also enable dtoverlay=ov5647 under the [all] section (not sure if this is really needed, but doesn't hurt.)


That's great that you got it working. I'll give that a try tomorrow on my setup and see if it works for me. I did order a V2 camera, but it hasn't arrived yet, but I can use that on another project if the earlier version works well

Well, didn't work for me, so guessing my V1.3 camera may be a clone and not based on the same camera chipset as yours. All good, I'll wait for my V2 camera to arrive