Can't install plugins after octoprint 1.5.2 update on octopi 0.17.0

What is the problem?

I Can't install plugins via plugin manager after octoprint 1.5.2 update on octopi 0.17.0
I can see the list of plugins in the plugin manager. When I want to install a plugin , the small install window of plugin open (normal) but it download/install nothing.


after fresh flashing of octoprint out of the box
Plugin install by plugin manager on octoprint 1.4.x => OK
Plugin install by plugin manager after octoprint 1.5.2 upgrade => FAIL

I'm able to install plugin by SSH following this command : /home/pi/oprint/bin/pip install plugin-url

Please help me !!!

What did you already try to solve it?

I did :

  • sudo apt-get update and sudo apt-get upgrade by SSH => no changes
  • update pip version to pip-20.3.1 by using command : /home/pi/oprint/bin/pip install --upgrade pip
    => update successful, but no changes
  • update python2 to python3 via your script given in the blog thread Upgrade your OctoPrint install to Python 3 => no changes

Have you tried running in safe mode and if so did it solve the issue?

no, because in safe mode I can't install plugin

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)
octoprint.log (171.2 KB) plugin_pluginmanager_console.log (92.2 KB)
I found nothing in LOG, and I suspect that it's an web ui issue because it does not log anything when I run a plugin install

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octopi version : 0.17.0
Octoprint version : 1.5.2

Thankfully I did :wink:

2020-12-14 11:07:14,230 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

It's due to this. Your Pi doesn't get enough power, OctoPrint detects that and prevents plugin installation (as we have seen SIGNIFICANT issues with that in undervoltage scenarios). Sadly a bug in 1.5 makes it so it the install dialog still pops up but then installation fails due to the detected undervoltage.

In any case, your Pi needs a better power supply, the current one isn't cutting it.

Actually I experienced the same problem today after having reinstalled octopi on a new sd card and upgraded octoprint to 1.5.2.
When restoring plugins using the command "~/oprint/bin/octoprint plugins backup:restore ~/".
None of the plugins were restored.

I'm using the recommended Power Supply and do NOT have an undervoltage error.

I was able to restore the plugins one by one using pip.

@poulanker No, you didn't experience the same problem, you experienced a different one:

That one is currently being investigated.

I stand corrected :slight_smile:
I did not look far enough back in the reported issues.

dear Foosel,

I have a dedicated 15W (5V 3A) Meanwell PSU for the RPI4. I think the error is a false positive provided because the RPI is feeded by GPIO port. I have disable this option (see below), and I never had his problem before.

I'm shearching the thread which speak about this case.
In all way, if the PSU are responsible, I couldn't install plugins thru pip command line ?
I have another SD card with fresh install on it.
I purpose the following process to generate logs :

  • from first run , I disable the under power detection
  • install one or more plugins by plugin manager
  • update octoprint to 1.5.2
  • trying to install plugin thru plugin manager

after I post Logs
do you agree with this process ?

False positives are not a thing - your power supply is not providing the correct power. Maybe it is the cables, the connector or other. You say it is provided through the GPIO pins - note that if you are using something like DuPont style connectors, these are actually worse than the USB port.

Whether you like it or not, your Pi will be throttled. This, you cannot disable, nor can any user space software, since it is built into the Raspberry Pi OS. What OctoPrint does, is limit what users can do to install/update, since in the past it has been known to cause all number of issues. It also warns users that they really should fix the problem.

Of course, you can still do things like install plugins manually but do not come and ask for help when it comes wrong, since you now know exactly what we are going to say :wink:

1 Like

Have you checked the correct voltage? Maybe the potentiometer is set wrong.

And as @Charlie_Powell said: Take care of good connectors. With a bad connection you can easily lose some 100 mVolts.

1 Like

For what it's worth. I had the same issue, swapped to a new/shorter usb cable and the low power issue stopped, and I was able to install plugins. Also using a 5v 3A charger.

uniquely though in my case, I am using a USB-C phone charger with an adapter to USB-A


Hello @Colby_Johnson!

Please don't use a charger. They can charge a phone, but they are not sufficient for powering a Pi.