Can't log into Octoprint

What is the problem?

I have been using this octoprint raspberry pi 4B for a couple months and it has worked flawlessly for the most part. But this morning when I went to log in my normal pi raspberry username and password did not work. I'm quite certain I did not change anything. However I did purchase a second raspberry pi 4B for a second 3D printer. I did connect that one to my second monitor and change the name of the octopi so it would not cause issues both being named the same thing.

What did you already try to solve it?

I searched on google and it brought me to these chat rooms and I read a couple articles on talking about not being able to log in. First one asked to view log so I tried that and got command not found. I tried source ~/oprint/bin/activate and got no such file or directoryI tried other commands as well. I did change the name of this raspberry pi from octopi to CR6seocto with a new password and all that did was change the hostname and log in password using a direct connection to a monitor and keyboard.

Have you tried running in safe mode?

don't know how to boot in safe mode

Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

could not access the logs

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


To clarify - are we talking the console/command line login, or the OctoPrint web UI?

Yes Sir Charlie I am connected to a monitor with the pi and a keyboard and mouse

You are not really answering the question. Are you having trouble logging in to the Raspberry Pi OS, or logging in to the OctoPrint web UI?

I am guessing it is the latter; you cannot do the source ~/oprint/bin/activate command unless you are logged in to the Raspberry Pi OS.

The pi and raspberry combination is for the OS only. When you first accessed the Web UI in a browser, you created a different set of username and password there.

I think I understand what you are saying and your assumptions based on my poor way of responding is correct. Let me reiterate if I try to log into the octoprint when it is connected to the printer and wifi I am unable to do so. When I bring the pi to my desk and connect it directly to a monitor I can log in, and when I did I changed the hostname of the pi from the desktop to CR6seocto to differentiate between the two pi's I have on the same network. After rebooting the pi it did show up on the network as the new host name but I am still unable to log in using wifi
and my safari from my Mac

how did you change the hostname? with the sudo raspi-config utility?
can you see the pi connected on the router? can you access it by the IP address?

I changed the host name using sudo raspi-config and yes the pi shows up in my WiFi network with the new name

Let me ask one more time. When you say, in the sentence above "log in to the octoprint", what EXACTLY do you mean? What program do you use? Putty? "ssh" from a command-line? A webbrowser? An app? (what app?)

When I use safari and try to log in with WiFi connection to the local device ip for example

All I want to be able to do is add a user and password to the existing octoprint session that I have on the monitor connected to the pi. I think I did not make it clear at all and for that my apologies. I recently had my medicine for diabetes upped and until I get used to my meds I am struggling with a high feeling from the more powerful doses. I guess I was just not thinking.

This may be what you want?

When you use Safari (or another browser), you are logging in to the web interface of OctoPrint. The user accounts for the web interface are a completely different set than what you use over SSH. Simply put pi and raspberry will not work in the browser. There is no default username and password for the web interface in the browser; only the username and password you came up with yourself when you first used the web interface of OctoPrint.

Thanks Field that I know already, what I need to find out is how to add or change that username and password because the one I made and was using is no longer working

When I SSH into it and enter what you showed me I get the following response: -bash: ~/oprint/bin/activate No such file or directory

Incidentally I am on Octoprint version 1.5.3 and OctoPi version 0.18.0

@Charlie_Powell posted a link that explains how to reset / change the OctoPrint username / password used with a web browser to view the OctoPrint web interface. This does require that you can successfully login to OctoPi using SSH.

If you cannot successfully login to OctoPi (using the username "pi" and the password that you changed from its default of "raspberry"), then there is a way to reset it by moving the microSD card back to the machine you used to flash the OctoPi image originally. Create a file octopi-password.txt on it, containing a new password as it's only line. Unmount, boot, login with the new password.

I did it exactly a you asked and it changed the password for when I am connected to a monitor and using a keyboard. Or in my terms when I log into the pi direct. When I go to my browser and type in the URL my pi is at in this case an example would be it brings up my log in screen, that is where I cannot find my username and or password to get into the octoprint control panel

You are supposed to enter source ~/oprint/bin/activate

It looks like you may have forgotten the source bit. If not, triple check that you typed a ~. Depending on your keyboard(-settings), that character may not have typed well. If it keeps being an issue, you can also try source /home/pi/oprint/bin/activate

Pi direct == OctoPi login. This username / password is also used to connect with SSH using PuTTY or other suitable SSH client.

Browser login == OctoPrint login. Use the instructions in the link provided by @Charlie_Powell to change / reset the username / password used for browser logins.

There are two different username / password combinations used for two separate logins. There are two different methods for resetting / changing each one. Both methods have been documented for you in this topic but you must choose the appropriate one and follow the instructions correctly. We can't do that for you.

Still not working I took a screen shot for you