Can't open SD Card after flashing in Windows 10

What is the problem?

After flashing the SD card with etcher I can not open the SD card in Windows 10 at all. I get a warning saying "You need to format the disk in drive E: before you can use it" This is my second time setting up octoprint. I confirmed the SD card had no issues prior. Etcher validates the image.


What did you already try to solve it?

I formatted it. The volume persisted. I deleted all the Volumes in diskpart. (wouldnt allow me to in Disk management.) Used etcher again to write the image. SD card could net be opened, same error. Repeat without formatting this time. Same thing. Repeat, repeat.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

When you copy the OctoPi image to an SD card using Etcher, there are (usually) two partitions created. The first is a Linux partition and the second is a small VFAT partition which contains the files in /boot.

When you attempt to mount this SD card on Windows, two drive letters will be assigned. The first is unreadable and may give you the format dialog, click Cancel. You should then be able to browse This PC and you will see the second letter which you can open.


Thanks @b-morgan, But I dont get any prompt to cancel as you say. All the alerts I get are posted above. Secondly, I inserted this SD card in the raspi and booted it. I SSHed in and made the wifi modifications to the cotopi-wpa-supplicant.txt file. When i go to save it says` [ File 'octopi-wpa-supplicant.txt' is unwritable ]

i had no trouble setting up octoprint last time. Advice?

try to edit the file with sudo :slight_smile:
for example sudo nano cotopi-wpa-supplicant.txt

1 Like

Hey! So I did this. Used sudo nano. Made the changes. I'm up and running now. Thanks. I wish I could understand why I had the issue in windows opening the SD card. I found a few others with the same issue and no post had a solution. All had to SSH into the Pi and gave up with windows.

1 Like

OctoPi is configured for a headless (i.e. no monitor, keyboard, mouse) Raspberry Pi. The The SD card has multiple partitions one of which will be recognized as a the root file system. "/" when inserted in the RPi and one of which contains "/boot" in the RPi file system but has a partition type that can be mounted on most desktop systems (Windows, MacOS, Linux, etc.).

On this desktop mountable file system are files like octopi-wpa-supplicant.txt which can be edited using a desktop editor (but not Windows Notepad unless it's the newest version). This file can be edited while the SD card is mounted on the desktop so that when the headless RPi is booted, it will immediately connect to a WiFi network.

I'm confused... The first alert you posted clearly has a Cancel button and the second alert you posted clearly shows that there are two partitions on the SD card, one FAT32 and one healthy but of unknown type.

I guess it doesn't matter anymore as you got it working but I'm adding this in case someone new has the same issue and stumbles across this thread.

Yes, it hit the cancel button to close that dialogue box but then nothing further happens. The E: drive / SD card shows in windows but there is no information about it. When you try to open it, it says the same thing about needing to be formatted. When you remove it and reinsert it, it says it needs to be formatted. When you click cancel nothing it just closes that box. When you try to open the E" drive again it says it needs to be formatted.

It's the same issue that was not solved in these posts:

I have a headless ESXi server, PiHole sever and an unRAID server so I'm familiar with how headless servers work. I would just like to troubleshoot this one issue since it's easier to edit the file in windows and I have a few more OctoPis to set up for my other printers.

I've tried again with another SD card. Same result. I think the last time I did this I used a Mac. I only have windows PCs now. I could try to pass through USB on my Ubuntu VM in ESXi but it seems like you should be able to edit the TXT file in Windows as others have.

11 posts were merged into an existing topic: Windows/macOS confusing users trying to download OctoPi zipped IMG

After flashing the SD card with Etcher, physically remove the SD card and reinsert it. This will cause Windows to re-read the partition table and then both partitions should be available.

Windows won't mount the ext4-based rootfs partition.

Nit picking... the other partition is available (and can be seen in Disk Management). You are correct, it is not mounted. Maybe "seen" would have been a better choice of words than "available".

1 Like

The issue is: there is no real issue here. The system is (somewhat) right and behaves as expected.
Windows does not understand Ext4 and thus complains that the partition needs formatting (because it wants it to be in a format it understands). We want the partition to stay formatted as Ext4. The partition is visible in the partition manager, but can't be mounted in Windows.

I hope this clears it up a bit.


IMO, this thread should be split into two threads (@OutsourcedGuru can you make that happen?). The replies having to do directly with the SD card should remain here. The replies that discuss curl should move to a new thread (with an appropriate title).

1 Like

Agreed and done.

1 Like