Can't update from Octoprint 14

I can't update my Octoprint 14 to anything newer.


What did you already try to solve it?

Have tried numerous times to update, but won't work

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Version 1.4.0 does not offer this Systeminfo Bundle, above says 1.6.0 and above do.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version 1.4.0, Octopi 3b+, Printer is Prusa MK3s, browser is Chrome, and Windows 10

The following is what shows up a being failed at the end of trying to update. Everything else seems to load fine.

Traceback (most recent call last):
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/cli/", line 176, in main
status =, args)
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/commands/", line 346, in run
session=session, autobuilding=True
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/", line 886, in build
assert have_directory_for_build
The update did not finish successfully. Please consult <code>octoprint.log</code> and <code>plugin_softwareupdate_console.log</code> for details.

Heyho :slight_smile:

Try this

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.