Can't update to 1.6.1 for an Exception error

What is the problem?

In short: I can't update to Octoprint 1.6.1

What did you already try to solve it?

I tried uninstalling any thrid party plugins, and running safe mode, but to no avail...

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No :frowning:

Systeminfo Bundle (1.4 MB)

Additional information about your setup

When I try to update, I get the following error message:

The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log` for details.

and the follwing red text in the dialogue:

Traceback (most recent call last):
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/cli/", line 176, in main
status =, args)
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/commands/", line 346, in run
session=session, autobuilding=True
File "/home/pi/oprint/local/lib/python2.7/site-packages/pip/_internal/", line 886, in build
assert have_directory_for_build

The printer then restarts, and all works well, but updating always fails :frowning:

This is your issue:

However, you are still running Python 2 for your install. You won't have seen the warnings introduced by 1.7.x, but OctoPrint 1.8.0 will drop support for Python 2 and you need to update it. So you could ignore fixing the update issue, because it will be included in upgrading your install.

Thx for you reply :slight_smile:

And yes, this seems to be it... But as I'm not very versed, what do you mean by:

"So you could ignore fixing the update issue, because it will be included in upgrading your install."?

Should I just "live with it" until the next update hits (so it will "resolve itself") or will I need to do a fresh install/update it some how later on?

Thx ^^

No. Follow the instructions for upgrading to Python 3, and that will include resolving any issues with regular updates.

Thank you., will do :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.