(Center Viewport / Zoom) In Does Not

The Problem:

I tried following this :

And got these "results"

It was set on "lower left"

So I tried "center", and …

Any suggestions ?

Additional information about your setup

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.3 Safari/605.1.15
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.python.pip: 20.3.3
env.python.version: 3.7.3
octoprint.version: 1.5.3
printer.firmware: Marlin Creality 3D

Does your model have a prime line or something at the edge of the printer? In the current release, the centre is based on the entire object. I believe there is some work for the future release that adjusts this and adds extra parameters.

1 Like

This is for the center of the print area of a delta printer.
Cartesian printers use lower left.

Center in the viewer does not mean to center on the print area, just in the view port.

But it should zoom...

Have you already tried safe mode? (BTW: I'm curious why you have deleted the template...)

1 Like

Tried safe mode - no different.

A "prime line", I believe so.
This is in the g-code start block:

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

It "primes" the extruder.
It is in EVERY print, not really "part of the model"

If there is a fix in the works, I can be patient.
This is more an annoyance than a bug to me.


It is changed for 1.6.0, found the PR

As far as octoprint and the printer are concerned, all of the GCODE is the whole model, so the prime line is "part of the model"

1 Like

Thanks, Charlie.
When is 1.6.0 scheduled to hit the street, please ?

There's hardly ever an ETA on new version release. Closest thing is watching the milestones on the OctoPrint repo.

1 Like

I installed 1.6 today.
On my Ender 3 Pro, the zoom now follows the current layer,
so after the first layer, the view is now what I was expecting.

However, now I cannot move the view on my Monoprice Mini Delta, only zoom in or out.
It seems to be centered on the build space, not the model.
I will try an off-center model and report back.

Any other MPMD owners seeing this ?

An off-center model shows interesting behavior.
If you select "Center viewport on model", it does.
If this option is not selected, you are centered on the build surface.

One or the other.
Nothing else.
I can deal with this limitation for the time being, but it is wonky behavior

It is a known bug, not identified in the Release Candidate phase of OctoPrint 1.6.0 unfortunately.

Not a major issue, so it will be fixed if necessary alongside other bug fixes into a 1.6.1 release.

I have no problem waiting for 1.6.1
Many thanks for the information.

1 Like

One more little thing:
Could we get the vertical scroll bar out of the viewport ?