Changing Wifi Settings

What is the problem?

I'm trying to change the wifi settings on my Pi Zero W running OctoPrint 1.9.3.

What did you already try to solve it?

Doing a search and asking AI says there should be a networking section in the UI of OctoPrint. I don't see one. I've also tried modifying the system config files on the SD card by editing on my windows laptop. I uncomment the lines, make the changes, but it doesn't take effect when restarting the Pi.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

didn't try

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues


Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible


Hello @gregp76 !

That one is funny. You see how smart AI is... :-1:

There is no UI section in OctoPrint for setting the WiFi parameters.
Reason: OctoPrint is platform independent. On a system that can run Python, you can install OctoPrint.

You can access an OctoPi setup either via SSH or by connecting a keyboard and Monitor/TV to the Pi and run raspi-config. Here you can change your WiFi credentials.

On other systems you can use their tools.

Or by the solution described here:

Super helpful. Thank you so much.

1 Like

Thanks for sharing! This finally makes sense!
First of all, this FAQ page didn't provide a solution for me (didn't work):

In my opinion, using raspi-config is THE #1 thing someone should try through SSH, rather than screwing with VIM and octopi-wpa-supplicant.txt.

The solution to change WiFi settings that I have used from my end (before I learned about raspi-config):

sudo iw wlan0 scan | grep SSID #this to scan for SSIDs if needed
sudo systemctl status NetworkManager
sudo systemctl start NetworkManager
sudo nmcli dev wifi connect "Fontaine Futuristics"  password 12356xxx

In order to make this persistent across reboots (example, because you need to dump UUID of the WIFI SSID):

pi@ender3pi:~ $ sudo systemctl enable NetworkManager ## enables autostart of NetworkManager
pi@ender3pi:~ $ sudo nmcli con
NAME                  UUID                                  TYPE      DEVICE
Wired connection 1    080e2f0c-c0a3-3471-a7dd-14546880ae6e  ethernet  eth0
Fontaine Futuristics  fe9d9b81-62a0-470b-97d3-c45f84cfaac4  wifi      wlan0
pi@ender3pi:~ $ sudo nmcli con mod "fe9d9b81-62a0-470b-97d3-c45f84cfaac4"  connection.autoconnect True
1 Like