Communication error - Ender 3 V2

What is the problem?

I get communication errors with my Ender 3 V2 connected to my RPi4, disconnects no matter what file. It was working fine for a few months?

What did you already try to solve it?

Different cables (short cable, not backpowering), different ports ports
Increase consecutive timeouts during long running commands
Request exclusive access to the serial port on/off
High speed connection on/off

Have you tried running in safe mode?

Yes and restoring previously working backup

Did running in safe mode solve the problem?


Systeminfo Bundle (149.3 KB)
New Text Document (2) - Copy.log (28.7 KB)
New Text Document (2).log (19.4 KB)

Additional information about your setup

Using Ender 3 V2 Marlin Firmware with BLTouch. Running 1.8.7, NO camera, official rpi4 psu, previous versions not working still

Help is greatly apricated

There are a lot of errors in the log related to octoeverywhere. Looking at the errors.. I don't see direct Serial errors. It looks like its all related to octoeverywhere.

2023-05-16 20:51:55,838 - octoprint.plugins.octoeverywhere - INFO - Main request http URL threw an exception: HTTPConnectionPool(host='', port=8080): Max retries exceeded with url: /?action=snapshot (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0xa3df87d0>: Failed to establish a new connection: [Errno 111] Connection refused'))
2023-05-16 20:51:55,839 - octoprint.plugins.octoeverywhere - ERROR - Main request failed and we have no more fallbacks. We DON'T have a main response.
2023-05-16 20:51:58,882 - octoprint.plugins.octoeverywhere - INFO - Snapshot fallback failed due to the http call having a bad status: 503
2023-05-16 20:53:42,289 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2023-05-16 20:53:45,294 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2023-05-16 20:53:48,299 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2023-05-16 20:53:51,304 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2023-05-16 20:53:54,309 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2023-05-16 20:53:57,313 - octoprint.util.comm - INFO - No response from printer after 6 consecutive communication timeouts, considering it dead.

Looking again at the Log, maybe the octoeverywhere is just a separate issue. I tend to think it is somehow related though. The log entries are bookended by octoeverywhere entries. Maybe there is something about the errors that are being produced by octoeverywhere that is affecting the systems ability to work with the Serial line processing. And all of this is happening while printing from the SD.

Maybe disable octoeverywhere and see if that helps.

I tried safemode and disabling removing octoeverywhere before, nothing seemed to change, but I can try again if that changes anything, would you know if a usb controller chip or something on the printer board or pi could not be working properly? I haven't came up with a way to test it yet, if you have any suggestion to test them it would be great, thanks for your response

Bump, Please help!!

Have you tried the usual Creality firmware thingies?

  1. Try wit/without SD card in the printer's SD card slot.

  2. Put tape on the 5V pin - Why and how

My firmware was working fine for a while the this issue appeared. Unfortunately, I have tried with/without sd card in printer and have taped up 5v pin.

serial.log (701.5 KB)
terminal.log (15.1 KB)
Bump, please help, im printing from sd card same error

Have you tried other firmware than from Creality?

Creality printers are infamous for EMI caused communication errors and are also infamous for being EMI generators. You can search this forum for "EMI" and find numerous topics many of which have solutions you can try.

A high quality, short, shielded USB cable with Ferrite beads is almost always part of the solution. The physical location of the RPi relative to the printer can have an effect. The physical routing of cables within the printer can have an effect. Other devices in the vicinity (including lights, fans, heaters, etc.) can have an effect.

My firmware was working fine for a couple months, then im not sure how this happened

Im using a very short cable and routed in different ways. Ive tried to turn of and on lights, heaters, microwave etc while connected but it doesnt seem to effect it. Since the cable is short I dont think it may get affected, please correct me if im wrong. Thanks for everyones help

This is unlikely to be the issue but if all other typical issues have been removed from a possible cause...

Maybe check your printers power supply levels. Could be that there is a power supply issue. If it were browning out or something, it could cause some issues. I would guess that your power supply is 12 or 24 volts and that gets converted to lower levels by the main board.

I would start at the top and take a look at the 12/24 level feeding the printer. If you can look at it both without load and underload that would be best. Its underload that is likely where you will find an issue/
You should not see a big difference in level when the printer is running a print.

If if that seems to be without issue, you may want to identify 5v on the main board and see if that level is low or dips underload.

While you are looking at the board, it occured to me that maybe you could have a lose wire in a terminal. Like maybe the heater block line. This could cause random noise if it were to move (making and breaking connection) during a print. In fact I would suggest you inspect all the wiring. Is it possible that specific movements are happening when you see the errors ?

It should be set to the correct voltage, I have inspected the wiring on the mainboard and I couldnt find anything wrong. Also tested under no load, still disconnects, possibly the electricity is browning out but not sure

The problem is the infamous CH340G chip the USB to serial converter. How do I know ? I struggled with this issue with a long time to no avail. Finally I resorted to bypassing it completely and connecting my RPI serial port directly to the printer , I had to de-solder the +5V supply to the chip and connect the Tx an Rx and ground to the pins of the CH340G. Now my connection is super reliable and never drops.

1 Like

Thank you so much your response, first person I have seen with some kind of answer like this, perchance do you know if all ender 3 v2 chips have this chip? - Couldnt find info online - I haven't seen many people with an issue like yours or talked about it. My printer was working fine with my Pi for awhile, but then suddenly didnt work.

As far as I know all the Ender 3 V2 do use that chip and that is probably why most Ender 3 users print from the SD card instead of USB. I know for a fact that the problem was caused by the chip because I replaced the whole board and the new board had the same issue , bypassing the chip solved all my communication issues however it's delicate tinkering.

1 Like

Not sure if im up for that since I havent really soldered anything like this before, my connection was fine for awhile then stopped. Im talking to creality support and got transferred to technical team, I told him some stuff and he just said "
Then you can solder the cable" Guess i can't expect much from them, anyways thanks so much for your help I'll see what happens after i talk the support again

Good luck , just to explain how I connected my Pi to the chip , I had to unsolder pin 16 (VCC) otherwise the chip interfered with the communicqtion and you have to connect the ground from the Pi to pin 1 or another ground point on the board , pin 2 (TXD) has to be connected to pin 10 (GPIO 15) and pin 3 connects to pin 8 (GPIO 14). Good luck !

Im very inexperienced with soldering, not sure if I could even get it done. If you have any pictures of the solder on the mainboard that would be absolutely great, if not no worries as I understand you may be busy.

Thanks alot again